aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index b97b81d54..3be8a73b2 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -31,6 +31,10 @@ INST_H_FILES = \
ephy-password-manager.h \
ephy-permission-manager.h
+BUILT_SOURCES = \
+ ephy-embed-type-builtins.c \
+ ephy-embed-type-builtins.h
+
libephyembed_la_SOURCES = \
ephy-adblock-manager.c \
downloader-view.c \
@@ -51,8 +55,7 @@ libephyembed_la_SOURCES = \
ephy-permission-manager.c \
print-dialog.c \
$(INST_H_FILES) \
- $(NOINST_H_FILES) \
- $(BUILT_SOURCES)
+ $(NOINST_H_FILES)
if ENABLE_CERTIFICATE_MANAGER
INST_H_FILES += \
@@ -64,6 +67,9 @@ libephyembed_la_SOURCES += \
ephy-x509-cert.c
endif
+nodist_libephyembed_la_SOURCES = \
+ $(BUILT_SOURCES)
+
libephyembed_la_CPPFLAGS = \
-I$(top_builddir)/lib \
-I$(top_srcdir)/embed/mozilla \
@@ -91,10 +97,6 @@ libephyembedfactory_la_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
$(AM_CFLAGS)
-BUILT_SOURCES = \
- ephy-embed-type-builtins.c \
- ephy-embed-type-builtins.h
-
CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
MAINTAINERCLEANFILES = $(stamp_files) $(BUILT_SOURCES)