aboutsummaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
index ce006dcd4..47504f4fd 100644
--- a/data/icons/Makefile.am
+++ b/data/icons/Makefile.am
@@ -5,3 +5,16 @@ SUBDIRS = \
32x32 \
48x48 \
scalable
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi