aboutsummaryrefslogtreecommitdiffstats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am113
1 files changed, 102 insertions, 11 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
index 47504f4fd..0b16c6e8b 100644
--- a/data/icons/Makefile.am
+++ b/data/icons/Makefile.am
@@ -1,20 +1,111 @@
-SUBDIRS = \
- 16x16 \
- 22x22 \
- 24x24 \
- 32x32 \
- 48x48 \
- scalable
+NULL =
+
+themes = \
+ hicolor \
+ $(NULL)
+
+icons = \
+ hicolor_actions_16x16_bookmark-view.png \
+ hicolor_actions_16x16_history-view.png \
+ hicolor_actions_16x16_location-entry.png \
+ hicolor_actions_22x22_bookmark-view.png \
+ hicolor_actions_22x22_history-view.png \
+ hicolor_actions_22x22_location-entry.png \
+ hicolor_actions_24x24_bookmark-view.png \
+ hicolor_actions_24x24_history-view.png \
+ hicolor_actions_24x24_location-entry.png \
+ hicolor_actions_32x32_bookmark-view.png \
+ hicolor_actions_32x32_history-view.png \
+ hicolor_actions_32x32_location-entry.png \
+ hicolor_actions_32x32_location-entry.svg \
+ hicolor_actions_scalable_bookmark-view.svg \
+ hicolor_actions_scalable_history-view.svg \
+ hicolor_actions_scalable_location-entry.svg \
+ hicolor_apps_16x16_gnome-web-browser.png \
+ hicolor_apps_22x22_gnome-web-browser.png \
+ hicolor_apps_24x24_gnome-web-browser.png \
+ hicolor_apps_32x32_gnome-web-browser.png \
+ hicolor_apps_scalable_gnome-web-browser.svg \
+ hicolor_places_16x16_bookmark-web.png \
+ hicolor_places_22x22_bookmark-web.png \
+ hicolor_places_24x24_bookmark-web.png \
+ hicolor_status_16x16_lock-broken.png \
+ hicolor_status_16x16_lock-insecure.png \
+ hicolor_status_16x16_lock-secure-checked.png \
+ hicolor_status_16x16_lock-secure.png \
+ hicolor_status_16x16_popup-hidden.png \
+ hicolor_status_22x22_popup-hidden.png \
+ hicolor_status_24x24_lock-broken.png \
+ hicolor_status_24x24_lock-insecure.png \
+ hicolor_status_24x24_lock-secure-checked.png \
+ hicolor_status_24x24_lock-secure.png \
+ hicolor_status_24x24_popup-hidden.png \
+ hicolor_status_32x32_popup-hidden.png \
+ hicolor_status_48x48_lock-broken.png \
+ hicolor_status_48x48_lock-insecure.png \
+ hicolor_status_48x48_lock-secure-checked.png \
+ hicolor_status_48x48_lock-secure.png \
+ hicolor_status_scalable_popup-hidden.svg \
+ $(NULL)
+
+source_icons = \
+ hicolor_actions_16x16_history-view.svg \
+ hicolor_actions_22x22_history-view.svg \
+ hicolor_actions_32x32_bookmark-view.svg \
+ hicolor_actions_32x32_history-view.svg \
+ hicolor_actions_16x16_bookmark-view.xcf \
+ hicolor_actions_22x22_bookmark-view.xcf \
+ hicolor_apps_16x16_gnome-web-browser.svg \
+ hicolor_apps_22x22_gnome-web-browser.svg \
+ hicolor_apps_32x32_gnome-web-browser.svg \
+ hicolor_places_16x16_bookmark-web.svg \
+ hicolor_places_22x22_bookmark-web.svg \
+ hicolor_status_16x16_popup-hidden.xcf \
+ hicolor_status_22x22_popup-hidden.xcf \
+ hicolor_status_32x32_popup-hidden.svg \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(icons) \
+ $(source_icons) \
+ $(NULL)
+
+###############################################################################
gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
update-icon-cache:
@-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
+ for theme in $(themes); do \
+ $(gtk_update_icon_cache) $(datadir)/icons/$$theme; \
+ done; \
else \
echo "*** Icon cache not updated. After (un)install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
+ for theme in $(themes); do \
+ echo "*** $(gtk_update_icon_cache) $(datadir)/icons/$$theme"; \
+ done; \
fi
+
+install-icons:
+ for icon in $(icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+uninstall-icons:
+ -for icon in $(icons); do \
+ THEME=`echo $$icon | cut -d_ -f1`; \
+ CONTEXT=`echo $$icon | cut -d_ -f2`; \
+ SIZE=`echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+ rm -f $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done
+
+install-data-local: install-icons update-icon-cache
+
+uninstall-local: uninstall-icons update-icon-cache