aboutsummaryrefslogtreecommitdiffstats
path: root/data/chrome/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/chrome/Makefile.am')
-rw-r--r--data/chrome/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/data/chrome/Makefile.am b/data/chrome/Makefile.am
new file mode 100644
index 000000000..155e8aa83
--- /dev/null
+++ b/data/chrome/Makefile.am
@@ -0,0 +1,16 @@
+manifestdir = $(pkgdatadir)/chrome
+manifest_in_files = epiphany.manifest.in
+manifest_DATA = $(manifest_in_files:.manifest.in=.manifest)
+
+%.manifest: %.manifest.in
+ @sed -e "s!@CHROMEDIR@!$(pkgdatadir)/chrome!g" $< > $@
+
+brandingdir = $(manifestdir)/branding
+branding_in_files = \
+ brand.dtd.in \
+ brand.properties.in
+branding_DATA = $(branding_in_files:%.in=%)
+
+EXTRA_DIST = \
+ $(manifest_in_files) \
+ $(branding_in_files)