aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 242789b84..b52ff8fa1 100644
--- a/configure.in
+++ b/configure.in
@@ -180,8 +180,8 @@ MOZILLA_VERSION="`$PKG_CONFIG --modversion mozilla-gtkmozembed`"
dnl allow user to override the autodetected mozilla version
dnl - without arguments for cvs head
AC_ARG_WITH(mozilla-snapshot,
- AC_HELP_STRING([--with-mozilla-snapshot@<:@=1.3|1.4a|trunk@:>@],
- [Whether to try building against mozilla 1.3|1.4a|trunk
+ AC_HELP_STRING([--with-mozilla-snapshot@<:@=1.3|1.3.1|1.4a|trunk@:>@],
+ [Whether to try building against mozilla 1.3|1.3.1|1.4a|trunk
snapshot. @<:@guessed@:>@]),
[autodetect=" (guessed: $MOZILLA_VERSION)"; MOZILLA_VERSION="$withval"])
@@ -189,13 +189,14 @@ AC_MSG_RESULT($MOZILLA_VERSION$autodetect)
case "$MOZILLA_VERSION" in
1.3) MOZILLA_SNAPSHOT=6 ;;
+1.3.1) MOZILLA_SNAPSHOT=6 ;;
"") MOZILLA_SNAPSHOT=7 ;;
1.4a) MOZILLA_SNAPSHOT=7 ;;
1.4b) MOZILLA_SNAPSHOT=7 ;;
trunk) MOZILLA_SNAPSHOT=7 ;;
*) AC_ERROR([
*****************************************************************************
-Epiphany can be built using mozilla 1.3, 1.4a, 1.4b or trunk snapshot, but the
+Epiphany can be built using mozilla 1.3, 1.3.1, 1.4a, 1.4b or trunk snapshot, but the
version available is $MOZILLA_VERSION.
When using mozilla trunk snapshot successful build is not guaranteed due to