aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8df91ae56..ff20c2611 100644
--- a/configure.in
+++ b/configure.in
@@ -173,7 +173,7 @@ dnl allow user to override the autodetected mozilla version
dnl - without arguments for cvs head
AC_ARG_WITH(mozilla-snapshot,
AC_HELP_STRING([--with-mozilla-snapshot@<:@=1.4|1.4.1|1.5|1.6a|1.6b|trunk@:>@],
- [Whether to try building against mozilla 1.4|1.4.1|1.5|1.6a|1.6b|trunk
+ [Whether to try building against mozilla 1.4|1.4.1|1.5|1.6a|1.6b|1.6|1.7a|trunk
snapshot. @<:@guessed@:>@]),
[autodetect=" (guessed: $MOZILLA_VERSION)"; MOZILLA_VERSION="$withval"])
@@ -182,15 +182,18 @@ AC_MSG_RESULT($MOZILLA_VERSION$autodetect)
case "$MOZILLA_VERSION" in
1.4) MOZILLA_SNAPSHOT=8 ;;
1.4.1) MOZILLA_SNAPSHOT=9 ;;
+1.4.2) MOZILLA_SNAPSHOT=9 ;;
1.5a) MOZILLA_SNAPSHOT=10 ;;
1.5b) MOZILLA_SNAPSHOT=11 ;;
1.5) MOZILLA_SNAPSHOT=11 ;;
1.6a) MOZILLA_SNAPSHOT=12 ;;
1.6b) MOZILLA_SNAPSHOT=13 ;;
+ 1.6) MOZILLA_SNAPSHOT=13 ;;
+ 1.7a) MOZILLA_SNAPSHOT=13 ;;
trunk) MOZILLA_SNAPSHOT=13 ;;
*) AC_ERROR([
*****************************************************************************
-Epiphany can be built using Mozilla 1.4, 1.4.1, 1.5, 1.6a, 1.6b or
+Epiphany can be built using Mozilla 1.4, 1.4.1, 1.5, 1.6a, 1.6b, 1.6, 1.7a or
trunk snapshot, but the version available is $MOZILLA_VERSION.
When using Mozilla trunk snapshot, a successful build is not guaranteed due