aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e13e4b9e8..a68f3e98b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,12 +335,11 @@ AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
[[#include <nsIURI.h>
#include <nsIGlobalHistory.h>
- #include <docshell/nsIGlobalHistory2.h>
- #include <history/nsIBrowserHistory.h>]],
- [[nsIBrowserHistory *p;
+ #include <docshell/nsIGlobalHistory2.h>]],
+ [[nsIGlobalHistory2 *p;
p->AddURI(nsnull,PR_FALSE,PR_FALSE,nsnull);]]
)],
- [AC_DEFINE([MOZ_NSIBROWSERHISTORY_ADDURI_WITH_REFERRER],[1],[Define if nsIGlobalHistory2::AddURI takes a referrer]) result=yes],
+ [AC_DEFINE([MOZ_NSIGLOBALHISTORY2_ADDURI_WITH_REFERRER],[1],[Define if nsIGlobalHistory2::AddURI takes a referrer]) result=yes],
[result=no])
AC_MSG_RESULT([$result])