aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f5a708c8..34886e01e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -531,6 +531,8 @@ fi
# Additional features
# *******************
+# Zeroconf bookmarks sites
+
AC_MSG_CHECKING([whether to enable zeroconf bookmarks support])
AC_ARG_ENABLE([zeroconf],
AS_HELP_STRING([--enable-zeroconf],[Whether to enable zeroconf bookmarks support (default:disabled)]),
@@ -543,6 +545,24 @@ fi
AM_CONDITIONAL([ENABLE_ZEROCONF],[test "x$enable_zeroconf" = "xyes"])
+# Certificates manager
+
+if test "$enable_psm" = "yes"; then
+
+AC_MSG_CHECKING([whether to build the certificates manager])
+AC_ARG_ENABLE([certificate-manager],
+ AS_HELP_STRING([--enable-certificate-manager],[Whether to enable the certificate manager (experimental; default:disabled)]),
+ [],[enable_certificate_manager=no])
+AC_MSG_RESULT([$enable_certificate_manager])
+
+fi
+
+if test "$enable_certificate_manager" = "yes"; then
+ AC_DEFINE([ENABLE_CERTIFICATE_MANAGER],[1],[Define to enable the certificate manager build])
+fi
+
+AM_CONDITIONAL([ENABLE_CERTIFICATE_MANAGER],[test "$enable_certificate_manager" = "yes"])
+
# *******************************
# Add warning flags
# *******************************