aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6ee1d9e42..8b4a5ac23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -363,6 +363,16 @@ GECKO_CHECK_HEADERS([windowwatcher],[nsINonBlockingAlertService.h])
GECKO_CHECK_HEADERS([docshell],[nsIGlobalHistory3.h])
+# Check for nsIIOService2.h
+# Added in 1.9
+
+GECKO_CHECK_HEADERS([necko],[nsIIOService2.h])
+
+# Check for nsIMutableArray.h
+# Split out into its own header in 1.9
+
+GECKO_CHECK_HEADERS([xpcom],[nsIMutableArray.h])
+
# Check for some contractIDs that we need but are provided by extensions
# which may or may not have been built.