aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6e93fac69..200ce4441 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,10 +183,10 @@ dnl *******
AC_MSG_CHECKING([which gecko to use])
AC_ARG_WITH([mozilla],
- AS_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|thunderbird@:>@],
+ AS_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|xulrunner|thunderbird@:>@],
[Which gecko engine to use (default: autodetect)]))
-GECKOS="firefox mozilla-firefox seamonkey mozilla thunderbird mozilla-thunderbird"
+GECKOS="firefox mozilla-firefox seamonkey mozilla xulrunner thunderbird mozilla-thunderbird"
gecko=$with_mozilla
if test "x$gecko" = "x"; then
@@ -212,6 +212,7 @@ mozilla) min_version=1.7.9 flavour=mozilla ;;
seamonkey) min_version=1.0 flavour=mozilla ;;
*firefox) min_version=1.0.5 flavour=toolkit ;;
*thunderbird) min_version=1.0.5 flavour=toolkit ;;
+xulrunner) min_version=1.8 flavour=toolkit ;;
esac
MOZILLA=$gecko