aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0526657a4..21a5056d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,10 +207,10 @@ dnl **********************************
dnl FIXME find a m4/autoconf guru who can distill this into a nice macro
AC_LANG_PUSH([C++])
-_SAVE_CFLAGS=$CXXFLAGS
-_SAVE_CPPFLAGS=$CPPFLAGS
+_SAVE_CXXFLAGS="$CXXFLAGS"
+_SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="-I$MOZILLA_INCLUDE_ROOT -I$MOZILLA_INCLUDE_ROOT/pipnss `$PKG_CONFIG --cflags-only-I $MOZILLA-xpcom`"
-CXXFLAGS="$_SAVE_CXXFLAGS $AM_CXXFLAGS `$PKG_CONFIG --cflags-only-other $MOZILLA-xpcom`"
+CXXFLAGS="$CXXFLAGS $AM_CXXFLAGS `$PKG_CONFIG --cflags-only-other $MOZILLA-xpcom`"
dnl Sigh Gentoo has a rubbish header layout
dnl http://bugs.gentoo.org/show_bug.cgi?id=100804