aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b5d1d1b9..51638e4c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,16 +38,10 @@ DISTCHECK_CONFIGURE_FLAGS = \
# Ignore gtk theme cache files on distcheck
distuninstallcheck_listfiles = find . -type f -print | grep -v 'icon-theme.cache'
-# Build ChangeLog from SVN history (r7394 was the first ChangeLog-less checkin).
-# Only build this when in an svn checkout.
-
+# Build ChangeLog from git history
ChangeLog:
@if test -f $(top_srcdir)/.git/HEAD; then \
git log --stat > $@; \
- elif test -f $(top_srcdir)/.svn/entries; then \
- svn log -v --xml -r HEAD:7394 $(SVN_ROOT)/$(SVN_MODULE)/$(SVN_BRANCH) | \
- xsltproc --stringparam strip-prefix "$(SVN_MODULE)/$(SVN_BRANCH)" \
- --stringparam include-rev "yes" $(top_srcdir)/svn2cl.xsl - > $@; \
fi
dist: ChangeLog