aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDiego Escalante Urrelo <diegoe@igalia.com>2012-05-24 11:21:27 +0800
committerDiego Escalante Urrelo <diegoe@igalia.com>2012-05-24 12:51:36 +0800
commit848eda70900d77f2acb49c8a5558f01d5720623d (patch)
tree01d06a465ae2ed4c794a8cde008f70b23b0e3900 /tests/Makefile.am
parentb3804abc15d4cc0aa927a5295d6552d4eb5e0626 (diff)
downloadgsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.tar
gsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.tar.gz
gsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.tar.bz2
gsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.tar.lz
gsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.tar.xz
gsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.tar.zst
gsoc2013-epiphany-848eda70900d77f2acb49c8a5558f01d5720623d.zip
tests: add ephy-file-helpers-test
Test API for file switch, tmp file creation, downloads, desktop directories. Take two of this test. Updated for ephy-file-helpers API changes. Previously reverted on 185ab751c20a825f832efd89a7cfbd75fa09e20c. https://bugzilla.gnome.org/show_bug.cgi?id=673337
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c44b95706..ee6f2d3a4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@ noinst_PROGRAMS = \
test-ephy-download \
test-ephy-embed-single \
test-ephy-embed-utils \
+ test-ephy-file-helpers \
test-ephy-history \
test-ephy-location-entry \
test-ephy-migration \
@@ -120,6 +121,12 @@ test_ephy_embed_single_SOURCES = \
test_ephy_embed_utils_SOURCES = \
ephy-embed-utils-test.c
+test_ephy_file_helpers_SOURCES = \
+ ephy-file-helpers-test.c
+test_ephy_file_helpers_CPPFLAGS = \
+ -DTOP_SRC_DIR=\"$(abs_top_srcdir)\" \
+ $(AM_CPPFLAGS)
+
test_ephy_history_SOURCES = \
ephy-history-test.c