aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDiego Escalante Urrelo <diegoe@igalia.com>2012-04-02 08:27:09 +0800
committerDiego Escalante Urrelo <diegoe@igalia.com>2012-04-30 08:15:32 +0800
commitd1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe (patch)
tree3de229f977528d10f5e7280251907dcb2e8fa3c8 /tests/Makefile.am
parentcebb6d5f7baf01520e02d2434612c57fe878acea (diff)
downloadgsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.tar
gsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.tar.gz
gsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.tar.bz2
gsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.tar.lz
gsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.tar.xz
gsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.tar.zst
gsoc2013-epiphany-d1ba46b3f4a4e2afbffe5a0ab2543462caea0bbe.zip
tests: add ephy-file-helpers-test
Test API for file switch, tmp file creation, downloads, desktop directories. https://bugzilla.gnome.org/show_bug.cgi?id=673337
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cb0944267..c116dbbdf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@ noinst_PROGRAMS = \
test-ephy-download \
test-ephy-embed-single \
test-ephy-embed-utils \
+ test-ephy-file-helpers \
test-ephy-history \
test-ephy-location-entry \
test-ephy-search-entry \
@@ -119,6 +120,12 @@ test_ephy_embed_single_SOURCES = \
test_ephy_embed_utils_SOURCES = \
ephy-embed-utils-test.c
+test_ephy_file_helpers_SOURCES = \
+ ephy-file-helpers-test.c
+test_ephy_file_helpers_CPPFLAGS = \
+ -DTOP_SRC_DIR=\"$(abs_top_srcdir)\" \
+ $(AM_CPPFLAGS)
+
test_ephy_history_SOURCES = \
ephy-history-test.c