aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-06-14 13:33:35 +0800
committerXan Lopez <xan@igalia.com>2012-06-14 14:44:02 +0800
commit979434a28ef2025f66655ceb83c7fbfd9fb48d7f (patch)
treebcd93b2f217020b972a3872535905252869554f4 /tests/Makefile.am
parent4873a591b6e90a6df99e7d0965c93b74bf4fec85 (diff)
downloadgsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.tar
gsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.tar.gz
gsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.tar.bz2
gsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.tar.lz
gsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.tar.xz
gsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.tar.zst
gsoc2013-epiphany-979434a28ef2025f66655ceb83c7fbfd9fb48d7f.zip
tests: add the beginnings of ephy-session unit testing
For now a simple test that verifies that loading a session works. We need to link with the resource files, which is unfortunate, but I'm not sure there's a way around it since this test will actually spawn a full EphyWindow (ie, it's not only testing the session or shell code but the entire browser as a side effect).
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3e3b00d92..985f6772a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -9,6 +9,7 @@ noinst_PROGRAMS = \
test-ephy-location-entry \
test-ephy-migration \
test-ephy-search-entry \
+ test-ephy-session \
test-ephy-sqlite \
test-ephy-web-view \
$(NULL)
@@ -141,6 +142,11 @@ test_ephy_migration_SOURCES = \
test_ephy_search_entry_SOURCES = \
ephy-search-entry-test.c
+test_ephy_session_SOURCES = \
+ ephy-session-test.c \
+ $(top_builddir)/src/epiphany-resources.c \
+ $(top_builddir)/src/epiphany-resources.h
+
test_ephy_sqlite_SOURCES = \
ephy-sqlite-test.c