aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2009-08-26 16:44:28 +0800
committerXan Lopez <xan@gnome.org>2009-08-26 16:45:38 +0800
commiteea4e5155ed3102ee21c57958a29603ed0f5166f (patch)
treea491d714dd8c7bc61c5a00eaf74dbff952e808c1 /src/Makefile.am
parentec783faa3c1737dfd80fd53a8113bbb3aa1c06a0 (diff)
downloadgsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.gz
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.bz2
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.lz
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.xz
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.tar.zst
gsoc2013-epiphany-eea4e5155ed3102ee21c57958a29603ed0f5166f.zip
Import passwords from the ephy/gecko profile on first run.
This feature requires NSS, so NSS is added as an optional dependency, enabled by default. Can be disabled with --disable-nss, but then passwords won't be imported.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 330326648..492a7688c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -140,6 +140,18 @@ libephymain_la_SOURCES += \
libephymain_la_CFLAGS += $(SEED_CFLAGS)
endif # ENABLE_SEED
+if ENABLE_NSS
+NOINST_H_FILES += \
+ ephy-nss-glue.h \
+ $(NULL)
+
+libephymain_la_SOURCES += \
+ ephy-nss-glue.c
+ $(NULL)
+
+libephymain_la_CFLAGS += $(NSS_CFLAGS)
+endif # ENABLE_NSS
+
epiphany_SOURCES = ephy-main.c
epiphany_CPPFLAGS = \
@@ -181,6 +193,10 @@ if ENABLE_SEED
epiphany_LDADD += $(SEED_LIBS)
endif # ENABLE_SEED
+if ENABLE_NSS
+epiphany_LDADD += $(NSS_LIBS)
+endif # ENABLE_NSS
+
if ENABLE_NETWORK_MANAGER
epiphany_LDADD += \
$(NETWORK_MANAGER_LIBS)