aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2011-12-13 23:45:10 +0800
committerXan Lopez <xan@igalia.com>2011-12-14 23:30:21 +0800
commitc1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9 (patch)
tree407b07bc318b263f518747ece8e668b933f9ed04 /src/Makefile.am
parent1ce161d56a3db3c436e5fbf888472c1f864cebb8 (diff)
downloadgsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.tar
gsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.tar.gz
gsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.tar.bz2
gsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.tar.lz
gsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.tar.xz
gsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.tar.zst
gsoc2013-epiphany-c1c74c929c1e773d1f79d1b3bd0cf10bb572f8f9.zip
Remove custom EphyToolbar in favor of a vanilla GtkToolbar
This allows us to stop using EggEditableToolbar here, we just load a normal toolbar from GtkUIManager in EphyWindow. The special toolbar actions and methods have been moved to EphyWindow too, mostly in a mechanical fashion (probably some simplifications are possible). The code in the bookmarks UI that depended on EphyToolbar has been #if zeroed instead of porting it, since it will go away in the near future too. https://bugzilla.gnome.org/show_bug.cgi?id=664483
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 97418adb0..84b707883 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,7 +30,6 @@ NOINST_H_FILES = \
ephy-navigation-up-action.h \
ephy-password-info.h \
ephy-toolbars-model.h \
- ephy-toolbar.h \
languages.h \
pdm-dialog.h \
popup-commands.h \
@@ -73,7 +72,6 @@ libephymain_la_SOURCES = \
ephy-session.c \
ephy-shell.c \
ephy-toolbars-model.c \
- ephy-toolbar.c \
ephy-window.c \
pdm-dialog.c \
popup-commands.c \
@@ -243,7 +241,6 @@ EPHY_GIR_H_FILES = \
$(top_srcdir)/src/ephy-notebook.h \
$(top_srcdir)/src/ephy-session.h \
$(top_srcdir)/src/ephy-shell.h \
- $(top_srcdir)/src/ephy-toolbar.h \
$(top_srcdir)/src/ephy-window.h \
$(NULL)
@@ -274,7 +271,6 @@ EPHY_GIR_C_FILES = \
$(top_srcdir)/src/ephy-notebook.c \
$(top_srcdir)/src/ephy-session.c \
$(top_srcdir)/src/ephy-shell.c \
- $(top_srcdir)/src/ephy-toolbar.c \
$(top_srcdir)/src/ephy-window.c \
$(NULL)