aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-09-29 16:10:37 +0800
committerXan Lopez <xan@igalia.com>2012-10-01 04:46:04 +0800
commit253ce5aa8e437687f329d3d51469fdabda3ee8d7 (patch)
tree275cb8bf461cd2847465c6772d69c036cf8ab2fe /src/Makefile.am
parent892cab7e083e801b5fb5e7047b6305cfe9acd7b6 (diff)
downloadgsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.tar
gsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.tar.gz
gsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.tar.bz2
gsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.tar.lz
gsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.tar.xz
gsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.tar.zst
gsoc2013-epiphany-253ce5aa8e437687f329d3d51469fdabda3ee8d7.zip
Import adblock extension into the source tree
This commit imports the adblock extension from 'epiphany-extensions' with as few modifications as possible. Further modifications and simplifications are possible, but for now we just load it unconditionally, enabled. We have it in the src/ directory because it depends on some high-level objects in Epiphany (EphyExtension, EphyWindow), but in the future we'll probably move it to embed/, transforming it from an extension into just the specific implementation of our EphyAdblockManager object. https://bugzilla.gnome.org/show_bug.cgi?id=681657
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ada8e4716..2f3599538 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,9 @@ header_DATA = \
$(INST_H_FILES)
NOINST_H_FILES = \
+ adblock-ui.h \
ephy-action-helper.h \
+ ephy-adblock-extension.h \
ephy-combined-stop-reload-action.h \
ephy-encoding-dialog.h \
ephy-encoding-menu.h \
@@ -37,6 +39,7 @@ NOINST_H_FILES = \
pdm-dialog.h \
popup-commands.h \
prefs-dialog.h \
+ uri-tester.h \
window-commands.h
INST_H_FILES = \
@@ -51,7 +54,9 @@ INST_H_FILES = \
$(NULL)
libephymain_la_SOURCES = \
+ adblock-ui.c \
ephy-action-helper.c \
+ ephy-adblock-extension.c \
ephy-completion-model.c \
ephy-completion-model.h \
ephy-combined-stop-reload-action.c \
@@ -79,6 +84,7 @@ libephymain_la_SOURCES = \
popup-commands.c \
prefs-dialog.c \
window-commands.c \
+ uri-tester.c \
$(INST_H_FILES) \
$(NOINST_H_FILES) \
$(NULL)
@@ -112,6 +118,7 @@ libephymain_la_CFLAGS = \
$(AM_CFLAGS)
UI_FILES = \
+ resources/adblock.ui \
resources/epiphany-bookmark-editor-ui.xml \
resources/epiphany-history-window-ui.xml \
resources/epiphany-ui.xml \