aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-09-04 05:11:11 +0800
committerXan Lopez <xan@igalia.com>2012-09-04 19:23:13 +0800
commit18b87ec8068c5bf98aed9f507d43cba451dab665 (patch)
tree3df86b0f9c4b7b71bdaea9fd1cd93c1e0bdc30a8 /src/Makefile.am
parent0aff80b0d783422d0db25f59c434198205d4bed7 (diff)
downloadgsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.gz
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.bz2
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.lz
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.xz
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.tar.zst
gsoc2013-epiphany-18b87ec8068c5bf98aed9f507d43cba451dab665.zip
Add code coverage support
Needs a fairly recent gnome-common. To use do: - Run configure with --enable-code-coverage - Type 'make check-code-coverage' - Open the HTML results https://bugzilla.gnome.org/show_bug.cgi?id=683297
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0a01e931f..ada8e4716 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -108,6 +108,7 @@ endif
libephymain_la_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
$(WEBKIT_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS) \
$(AM_CFLAGS)
UI_FILES = \
@@ -168,6 +169,7 @@ epiphany_LDADD = \
$(top_builddir)/lib/libephymisc.la \
$(top_builddir)/lib/egg/libegg.la \
$(DEPENDENCIES_LIBS) \
+ $(CODE_COVERAGE_LDFLAGS) \
$(LIBINTL)
if !WITH_WEBKIT2