aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCrispin Flowerday <gnome@flowerday.cx>2005-08-02 06:07:31 +0800
committerCrispin Flowerday <crispin@src.gnome.org>2005-08-02 06:07:31 +0800
commitd5c0aa573a34f005f740886d4455cafd7dde5e29 (patch)
treee2ba6fb02fc47035af0c43f7c95900da342f87ac /src/Makefile.am
parent27ae7de50c2573f2f38dbaa83c2b6b76e9f385c7 (diff)
downloadgsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.tar
gsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.tar.gz
gsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.tar.bz2
gsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.tar.lz
gsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.tar.xz
gsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.tar.zst
gsoc2013-epiphany-d5c0aa573a34f005f740886d4455cafd7dde5e29.zip
Pipe the output of the pygtk_codegen program straight to epiphany.c to fix
2005-08-01 Crispin Flowerday <gnome@flowerday.cx> * src/Makefile.am (epiphany.c): Pipe the output of the pygtk_codegen program straight to epiphany.c to fix timestamp handling, which caused make to run rules on every invocation.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 80e8031d3..3ae99e5f0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -292,9 +292,7 @@ epiphany.c: epiphany.defs epiphany.override
--register $(PYGTK_DEFSDIR)/gdk-types.defs \
--register $(PYGTK_DEFSDIR)/gtk-types.defs \
--override $*.override \
- --prefix py$* $(<F) ) > gen-$@ \
- && ( cmp -s gen-$@ $@ || cp gen-$@ $@ ) \
- && rm -f gen-$@
+ --prefix py$* $(<F) ) > $@
CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)