aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-07-12 19:12:24 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-07-12 19:12:24 +0800
commit61f1dcadb9567d95440a6b0f4ea0863401c2934e (patch)
treee4bf62176d2b66f1ab7e3d14c2279d173aaabcc1 /src/Makefile.am
parent50a00ee6f89a730e2f991dec4696d2d94b602456 (diff)
downloadgsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.tar
gsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.tar.gz
gsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.tar.bz2
gsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.tar.lz
gsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.tar.xz
gsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.tar.zst
gsoc2013-epiphany-61f1dcadb9567d95440a6b0f4ea0863401c2934e.zip
Very simple plugin framework, unused for now. We will start making
2003-07-12 Marco Pesenti Gritti <marco@it.gnome.org> * configure.in: * plugins/.cvsignore: * plugins/Makefile.am: * plugins/sample/.cvsignore: * plugins/sample/Makefile.am: * plugins/sample/sample.c: (bmks_changed), (plugin_init), (plugin_exit): * src/Makefile.am: * src/ephy-plugin.c: (ephy_plugin_get_type), (ephy_plugin_new), (ephy_plugin_load), (ephy_plugin_unload), (ephy_plugin_class_init), (ephy_plugin_init), (ephy_plugin_finalize): * src/ephy-plugin.h: * src/ephy-shell.c: (ephy_shell_load_plugins), (ephy_shell_init), (ephy_shell_finalize): Very simple plugin framework, unused for now. We will start making something useful with it only post 1.0
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d8041ce11..53cb7c4c7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,6 +10,7 @@ INCLUDES = \
$(WARN_CFLAGS) \
$(EPIPHANY_DEPENDENCY_CFLAGS) \
-DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DPLUGINS_DIR=\""$(libdir)/epiphany/plugins"\" \
-DDATADIR=\""$(datadir)"\" \
-DPIXMAP_DIR=\""$(datadir)/pixmaps"\" \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
@@ -62,6 +63,8 @@ epiphany_bin_SOURCES = \
ephy-navigation-action.h \
ephy-notebook.c \
ephy-notebook.h \
+ ephy-plugin.c \
+ ephy-plugin.h \
ephy-shell.c \
ephy-shell.h \
ephy-spinner-action.c \