aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-13 03:04:48 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-13 03:04:48 +0800
commit3564d87bc51c44ac10645479f3523fff81d892f1 (patch)
tree96c9c817cd8ccc33c0188c8a7c7d311e618f4f4b /src/Makefile.am
parenta27be014985599ab073926bbf676846bdb2657c3 (diff)
downloadgsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.tar
gsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.tar.gz
gsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.tar.bz2
gsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.tar.lz
gsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.tar.xz
gsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.tar.zst
gsoc2013-epiphany-3564d87bc51c44ac10645479f3523fff81d892f1.zip
Add Toolbar toggle to document context menu in fullscreen mode.
2005-01-12 Christian Persch <chpe@cvs.gnome.org> * data/ui/epiphany-ui.xml: Add Toolbar toggle to document context menu in fullscreen mode. * lib/egg/egg-editable-toolbar.c: (set_fixed_style), (update_fixed), (egg_editable_toolbar_set_fixed): * lib/egg/egg-editable-toolbar.h: Changed to allow setting a toolbar as fixed, not just one item. * lib/widgets/ephy-search-entry.h: Add _ prefixed struct declarations. * po/POTFILES.in: Updated. * src/Makefile.am: A src/ephy-fullscreen-popup.c: A src/ephy-fullscreen-popup.h: * src/ephy-history-window.c: * src/ephy-shell.c: (ephy_shell_new_tab): A src/ephy-toolbar.c: A src/ephy-toolbar.h: * src/ephy-window.c: (destroy_fullscreen_popup), (ephy_window_destroy), (exit_fullscreen_clicked_cb), (get_toolbar_visibility), (sync_chromes_visibility), (ephy_window_fullscreen), (ephy_window_unfullscreen), (sync_tab_address), (sync_tab_icon), (sync_tab_navigation), (sync_tab_security), (sync_tab_load_status), (sync_tab_zoom), (show_embed_popup), (modal_alert_cb), (ephy_window_focus_in_event), (ephy_window_focus_out_event), (ephy_window_init), (ephy_window_activate_location): R src/toolbar.c: R src/toolbar.h: * src/window-commands.c: (window_cmd_load_location): Implemented in-toolbar exit button, and integrated status indicator in the exit fullscreen popup. Moved toolbar.[ch] to ephy-toolbar.[ch] for namespace correcness, and much-needed code cleanup.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b78060cc7..ed3cd35e2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,6 +29,7 @@ NOINST_H_FILES = \
ephy-automation.h \
ephy-encoding-dialog.h \
ephy-encoding-menu.h \
+ ephy-fullscreen-popup.h \
ephy-go-action.h \
ephy-history-window.h \
ephy-home-action.h \
@@ -38,12 +39,12 @@ NOINST_H_FILES = \
ephy-navigation-action.h \
ephy-tabs-menu.h \
ephy-toolbars-model.h \
+ ephy-toolbar.h \
ephy-toolbar-editor.h \
pdm-dialog.h \
popup-commands.h \
prefs-dialog.h \
ppview-toolbar.h \
- toolbar.h \
window-commands.h
INST_H_FILES = \
@@ -65,6 +66,7 @@ libephymain_la_SOURCES = \
ephy-encoding-menu.c \
ephy-extension.c \
ephy-extensions-manager.c \
+ ephy-fullscreen-popup.c \
ephy-go-action.c \
ephy-home-action.c \
ephy-history-window.c \
@@ -80,13 +82,13 @@ libephymain_la_SOURCES = \
ephy-tab.h \
ephy-tabs-menu.c \
ephy-toolbars-model.c \
+ ephy-toolbar.c \
ephy-toolbar-editor.c \
ephy-window.c \
pdm-dialog.c \
popup-commands.c \
prefs-dialog.c \
ppview-toolbar.c \
- toolbar.c \
window-commands.c \
$(INST_H_FILES) \
$(NOINST_H_FILES)