aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-01-26 05:52:27 +0800
committerChristian Persch <chpe@src.gnome.org>2006-01-26 05:52:27 +0800
commitdd06e70a33a386b716fedd68393885f45a343b68 (patch)
tree97e77dd243f3d714f0571a62b4db7c53cb17d2aa /src/Makefile.am
parent48828a1977fc21c6fc6d03fa6003a081bf14b017 (diff)
downloadgsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.tar
gsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.tar.gz
gsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.tar.bz2
gsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.tar.lz
gsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.tar.xz
gsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.tar.zst
gsoc2013-epiphany-dd06e70a33a386b716fedd68393885f45a343b68.zip
libnm-glib be-gone! Use NetworkManager directly via DBUS, by importing the
2006-01-25 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * data/epiphany.schemas.in: * embed/mozilla/Makefile.am: * embed/mozilla/mozilla-embed-single.cpp: * lib/ephy-prefs.h: * src/Makefile.am: * src/ephy-net-monitor.c: * src/ephy-net-monitor.h: * src/ephy-shell.c: (ephy_shell_sync_network_status), (impl_get_embed_single), (ephy_shell_dispose), (ephy_shell_get_net_monitor), (_ephy_shell_create_instance), (_ephy_shell_startup): * src/ephy-shell.h: libnm-glib be-gone! Use NetworkManager directly via DBUS, by importing the excellent net-monitor extension directly into Epiphany. Code by Jean-François Rameau.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2ab63564f..15b4ee5e6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -122,6 +122,12 @@ libephymain_la_CFLAGS = \
$(DBUS_CFLAGS) \
$(AM_CFLAGS)
+if ENABLE_NETWORK_MANAGER
+libephymain_la_SOURCES += \
+ ephy-net-monitor.c \
+ ephy-net-monitor.h
+endif
+
if ENABLE_PYTHON
NOINST_H_FILES += \
ephy-python.h \