aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-01-03 22:42:10 +0800
committerChristian Persch <chpe@src.gnome.org>2006-01-03 22:42:10 +0800
commit23858a10ce281167073b9e0b82375fc53256310a (patch)
tree6d59df47d5370d7384520ed6fcd1fe0e262235b6 /src/Makefile.am
parent440c60d5ce97f899426a8a12700277f8c06d11db (diff)
downloadgsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.gz
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.bz2
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.lz
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.xz
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.zst
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.zip
Don't include generated files in the tarball. Bug #319440.
2006-01-03 Christian Persch <chpe@cvs.gnome.org> * embed/Makefile.am: * embed/mozilla/Makefile.am: * lib/Makefile.am: * lib/egg/Makefile.am: * src/Makefile.am: * src/bookmarks/Makefile.am: Don't include generated files in the tarball. Bug #319440. R help/C/Makefile.am: R help/es/Makefile.am: R help/eu/Makefile.am: R help/fi/Makefile.am: R help/ja/Makefile.am: R help/uk/Makefile.am: Remove obsolete files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am39
1 files changed, 28 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 960dc9bc8..b6b6c1413 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,6 +8,8 @@ endif
bin_PROGRAMS = epiphany
+EXTRA_DIST =
+
CXXLD = $(CXX)
LINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
@@ -54,7 +56,6 @@ INST_H_FILES = \
ephy-window.h
libephymain_la_SOURCES = \
- $(TYPES_SOURCE) \
ephy-activation.c \
ephy-action-helper.c \
ephy-completion-model.c \
@@ -94,6 +95,9 @@ libephymain_la_SOURCES = \
$(INST_H_FILES) \
$(NOINST_H_FILES)
+nodist_libephymain_la_SOURCES = \
+ $(TYPES_SOURCE)
+
if ENABLE_CERTIFICATE_MANAGER
NOINST_H_FILES += \
ephy-cert-manager-dialog.h
@@ -135,9 +139,10 @@ libpyphany_la_SOURCES = \
ephy-python-extension.c \
ephy-python-extension.h \
ephy-python-loader.c \
- ephy-python-loader.h \
- $(BUILT_PYPHANY_SOURCE) \
- $(TYPES_SOURCE)
+ ephy-python-loader.h
+
+nodist_libpyphany_la_SOURCES = \
+ $(BUILT_PYPHANY_SOURCE)
libpyphany_la_CPPFLAGS = \
-I$(top_srcdir)/lib \
@@ -220,7 +225,7 @@ if ENABLE_PYTHON
pydefsdir = $(datadir)/pygtk/2.0/defs
pydefs_DATA = epiphany.defs
-EXTRA_DIST = \
+EXTRA_DIST += \
epiphany.override \
$(pydefs_DATA)
endif
@@ -281,6 +286,16 @@ stamp-ephy-type-builtins.h: $(INST_H_FILES) $(NOINST_H_FILES)
&& rm -f xgen-$(@F) \
&& echo timestamp > $(@F)
+ephy-dbus-server-bindings.h: $(top_srcdir)/data/epiphany-service.xml Makefile
+ $(DBUS_BINDING_TOOL) --prefix=ephy_activation --mode=glib-server $< > xgen-$(@F) \
+ && ( cmp -s xgen-$(@F) $(@F) || cp xgen-$(@F) $(@F) ) \
+ && rm -f xgen-$(@F)
+
+ephy-dbus-client-bindings.h: $(top_srcdir)/data/epiphany-service.xml Makefile
+ $(DBUS_BINDING_TOOL) --prefix=ephy_activation --mode=glib-client $< > xgen-$(@F) \
+ && ( cmp -s xgen-$(@F) $(@F) || cp xgen-$(@F) $(@F) ) \
+ && rm -f xgen-$(@F)
+
epiphany.c: epiphany.defs epiphany.override
( cd $(srcdir) && $(PYGTK_CODEGEN) \
--register $(PYGTK_DEFSDIR)/pango-types.defs \
@@ -289,12 +304,6 @@ epiphany.c: epiphany.defs epiphany.override
--override $*.override \
--prefix py$* $(<F) ) > $@
-ephy-dbus-server-bindings.h: $(top_builddir)/data/epiphany-service.xml
- $(DBUS_BINDING_TOOL) --prefix=ephy_activation --mode=glib-server $< > $@
-
-ephy-dbus-client-bindings.h: $(top_builddir)/data/epiphany-service.xml
- $(DBUS_BINDING_TOOL) --prefix=ephy_activation --mode=glib-client $< > $@
-
CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
MAINTAINERCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
@@ -471,3 +480,11 @@ check-python-binding:
#check-local: check-python-binding
endif
+
+dist-check-python-binding:
+if !ENABLE_PYTHON
+ @echo "Python bindings must be enabled in order to make dist!"
+ @false
+endif
+
+dist-hook: dist-check-python-binding