aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2008-03-28 23:06:31 +0800
committerChristian Persch <chpe@src.gnome.org>2008-03-28 23:06:31 +0800
commit0d86fa3258226628083b8340e6c20a78ca11f955 (patch)
tree21b803f57e1bd9a6b144ec4e4f0e592362ad27bf /src/Makefile.am
parent6605cb341e38ebaea954567a3d3180a7c11d0655 (diff)
downloadgsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.tar
gsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.tar.gz
gsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.tar.bz2
gsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.tar.lz
gsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.tar.xz
gsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.tar.zst
gsoc2013-epiphany-0d86fa3258226628083b8340e6c20a78ca11f955.zip
Allow building with xulrunner 1.9. Patch by Alexander Sack; part of bug #503657
svn path=/branches/gnome-2-22/; revision=8142
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6d8c4b968..19dffcd9d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -180,6 +180,16 @@ libpyphany_la_LIBADD = \
$(PYGTK_LIBS)
endif
+
+# we do this to force c++ linkage if we are using the glue and
+# are running gecko 1.9 because standalone glue embedders that use
+# gtk_moz_embed_* need to #include <gtkmozembed_glue.cpp>
+if HAVE_GECKO_1_9
+if HAVE_GECKO_XPCOM_GLUE
+nodist_EXTRA_epiphany_SOURCES = dummy.cpp
+endif
+endif
+
epiphany_SOURCES = ephy-main.c
epiphany_CPPFLAGS = \
@@ -194,6 +204,7 @@ epiphany_CPPFLAGS = \
epiphany_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
+ $(GECKO_CFLAGS) \
$(DBUS_CFLAGS) \
$(AM_CFLAGS)
@@ -214,6 +225,7 @@ endif
if WITH_GECKO_ENGINE
epiphany_LDADD += \
+ $(GECKO_LIBS) \
$(top_builddir)/embed/mozilla/libephymozillaembed.la
endif
@@ -234,7 +246,9 @@ epiphany_LDADD += $(LIBXUL_LIBS) -lxpcomglue
endif
if WITH_GECKO_ENGINE
+if !HAVE_GECKO_XPCOM_GLUE
epiphany_LDFLAGS += -R$(GECKO_HOME)
+endif
epiphany_LDADD += \
$(GECKO_LIBS) \
@@ -248,6 +262,7 @@ epiphany_LDADD += \
endif
epiphany_LDADD += \
+ $(GECKO_LIBS) \
$(DEPENDENCIES_LIBS) \
$(DBUS_LIBS) \
$(LIBINTL)