aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-03-28 04:15:47 +0800
committerXan Lopez <xan@igalia.com>2012-03-28 04:15:47 +0800
commitf1b56402b69be4b7f0507c7154765d7ff8260ef2 (patch)
treea15d7d44b13a7ca3ce3a20459a272d3c371d995d /src/Makefile.am
parent98e31b7886bad0eae162ec7c6513a1d20f306727 (diff)
downloadgsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.tar
gsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.tar.gz
gsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.tar.bz2
gsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.tar.lz
gsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.tar.xz
gsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.tar.zst
gsoc2013-epiphany-f1b56402b69be4b7f0507c7154765d7ff8260ef2.zip
Make the resources depend on the actual UI files
Otherwise we won't update them if the UI files change. To do this we need to move them from data/ui/ to src/, which is not great. Things would be easier with non-recursive Makefiles.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 15 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d9cb01db3..9e34a652f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,6 +8,7 @@ bin_PROGRAMS = epiphany
EXTRA_DIST = \
epiphany.gresource.xml \
+ $(UI_FILES) \
$(NULL)
headerdir = $(prefix)/include/epiphany/$(EPIPHANY_MAJOR)/epiphany
@@ -108,11 +109,21 @@ libephymain_la_CFLAGS = \
$(WEBKIT_CFLAGS) \
$(AM_CFLAGS)
-epiphany-resources.c: epiphany.gresource.xml
- glib-compile-resources --target=$@ --sourcedir=$(top_srcdir)/data/ui --generate-source --c-name epiphany $(srcdir)/epiphany.gresource.xml
+UI_FILES = \
+ epiphany-bookmark-editor-ui.xml \
+ epiphany-history-window-ui.xml \
+ epiphany-ui.xml \
+ epiphany.ui \
+ epiphany-application-menu.ui \
+ prefs-dialog.ui \
+ epiphany.css \
+ $(NULL)
+
+epiphany-resources.c: epiphany.gresource.xml $(UI_FILES)
+ glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-source --c-name epiphany $(srcdir)/epiphany.gresource.xml
-epiphany-resources.h: epiphany.gresource.xml
- glib-compile-resources --target=$@ --sourcedir=$(top_srcdir)/data/ui --generate-header --c-name epiphany $(srcdir)/epiphany.gresource.xml
+epiphany-resources.h: epiphany.gresource.xml $(UI_FILES)
+ glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-header --c-name epiphany $(srcdir)/epiphany.gresource.xml
EPIPHANY_RESOURCES = \
epiphany-resources.c \