aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMario Sanchez Prada <msanchez@igalia.com>2010-04-07 23:19:25 +0800
committerXan Lopez <xan@gnome.org>2010-04-20 21:07:58 +0800
commitede59b054c4af72cc41108db8aedafbcae1996de (patch)
tree3a5581d41025e4687777d376d53c4de490ebe5a3 /src/Makefile.am
parent384588b86e68ea692a8f99db86b45ca0cc54f804 (diff)
downloadgsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.tar
gsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.tar.gz
gsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.tar.bz2
gsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.tar.lz
gsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.tar.xz
gsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.tar.zst
gsoc2013-epiphany-ede59b054c4af72cc41108db8aedafbcae1996de.zip
Split EphyNavigationAction in one abstract class and two subclasses
To ease understanding and further modification of the two different usages for the EphyNavigationAction class (Back/Forward and Up buttons), all the code there was split so the common one is kept in the superclass, delegating the more specific parts in the implementations of the subclasses: History (back/forward) and Up buttons. Also updated usage of this class in EphyToolbar. Bug #539716 Signed-off-by: Xan Lopez <xan@gnome.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am120
1 files changed, 62 insertions, 58 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fd626dad5..44823a6b1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,28 +14,30 @@ header_DATA = \
$(INST_H_FILES)
NOINST_H_FILES = \
- ephy-action-helper.h \
- ephy-activation.h \
- ephy-encoding-dialog.h \
- ephy-encoding-menu.h \
- ephy-find-toolbar.h \
- ephy-fullscreen-popup.h \
- ephy-go-action.h \
- ephy-history-window.h \
- ephy-home-action.h \
- ephy-link-action.h \
- ephy-lockdown.h \
- ephy-location-action.h \
- ephy-navigation-action.h \
- ephy-password-info.h \
- ephy-tabs-menu.h \
- ephy-toolbars-model.h \
- ephy-toolbar.h \
- ephy-toolbar-editor.h \
- languages.h \
- pdm-dialog.h \
- popup-commands.h \
- prefs-dialog.h \
+ ephy-action-helper.h \
+ ephy-activation.h \
+ ephy-encoding-dialog.h \
+ ephy-encoding-menu.h \
+ ephy-find-toolbar.h \
+ ephy-fullscreen-popup.h \
+ ephy-go-action.h \
+ ephy-history-window.h \
+ ephy-home-action.h \
+ ephy-link-action.h \
+ ephy-lockdown.h \
+ ephy-location-action.h \
+ ephy-navigation-action.h \
+ ephy-navigation-history-action.h \
+ ephy-navigation-up-action.h \
+ ephy-password-info.h \
+ ephy-tabs-menu.h \
+ ephy-toolbars-model.h \
+ ephy-toolbar.h \
+ ephy-toolbar-editor.h \
+ languages.h \
+ pdm-dialog.h \
+ popup-commands.h \
+ prefs-dialog.h \
window-commands.h
INST_H_FILES = \
@@ -52,42 +54,44 @@ INST_H_FILES = \
$(NULL)
libephymain_la_SOURCES = \
- ephy-activation.c \
- ephy-action-helper.c \
- ephy-completion-model.c \
- ephy-completion-model.h \
- ephy-dbus.c \
- ephy-dbus.h \
- ephy-encoding-dialog.c \
- ephy-encoding-menu.c \
- ephy-extension.c \
- ephy-extensions-manager.c \
- ephy-find-toolbar.c \
- ephy-fullscreen-popup.c \
- ephy-go-action.c \
- ephy-home-action.c \
- ephy-history-window.c \
- ephy-link.c \
- ephy-link-action.c \
- ephy-location-action.c \
- ephy-lockdown.c \
- ephy-navigation-action.c \
- ephy-notebook.c \
- ephy-password-info.c \
- ephy-session.c \
- ephy-shell.c \
- ephy-statusbar.c \
- ephy-tabs-menu.c \
- ephy-toolbars-model.c \
- ephy-toolbar.c \
- ephy-toolbar-editor.c \
- ephy-window.c \
- pdm-dialog.c \
- popup-commands.c \
- prefs-dialog.c \
- window-commands.c \
- $(INST_H_FILES) \
- $(NOINST_H_FILES) \
+ ephy-activation.c \
+ ephy-action-helper.c \
+ ephy-completion-model.c \
+ ephy-completion-model.h \
+ ephy-dbus.c \
+ ephy-dbus.h \
+ ephy-encoding-dialog.c \
+ ephy-encoding-menu.c \
+ ephy-extension.c \
+ ephy-extensions-manager.c \
+ ephy-find-toolbar.c \
+ ephy-fullscreen-popup.c \
+ ephy-go-action.c \
+ ephy-home-action.c \
+ ephy-history-window.c \
+ ephy-link.c \
+ ephy-link-action.c \
+ ephy-location-action.c \
+ ephy-lockdown.c \
+ ephy-navigation-action.c \
+ ephy-navigation-history-action.c \
+ ephy-navigation-up-action.c \
+ ephy-notebook.c \
+ ephy-password-info.c \
+ ephy-session.c \
+ ephy-shell.c \
+ ephy-statusbar.c \
+ ephy-tabs-menu.c \
+ ephy-toolbars-model.c \
+ ephy-toolbar.c \
+ ephy-toolbar-editor.c \
+ ephy-window.c \
+ pdm-dialog.c \
+ popup-commands.c \
+ prefs-dialog.c \
+ window-commands.c \
+ $(INST_H_FILES) \
+ $(NOINST_H_FILES) \
$(NULL)
nodist_libephymain_la_SOURCES = \