aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-02-07 23:13:33 +0800
committerChristian Persch <chpe@src.gnome.org>2009-02-07 23:13:33 +0800
commit2e720b50fa23e3045d0869ba09a4d6a005e9e14c (patch)
tree3249821df198f34c00fa631df32abb0c06a7fb46 /src/Makefile.am
parent642eb45983933bf096844c0acb6b841fd5fa9ad3 (diff)
downloadgsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.tar
gsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.tar.gz
gsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.tar.bz2
gsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.tar.lz
gsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.tar.xz
gsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.tar.zst
gsoc2013-epiphany-2e720b50fa23e3045d0869ba09a4d6a005e9e14c.zip
Add seed support; use --enable-seed to check it out. Patch by Robert Carr.
svn path=/trunk/; revision=8756
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b6e08414f..0722c73b6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -124,6 +124,21 @@ libephymain_la_SOURCES += \
ephy-net-monitor.h
endif
+if ENABLE_SEED
+NOINST_H_FILES += \
+ ephy-seed-extension.h \
+ ephy-seed-loader.h \
+ $(NULL)
+
+libephymain_la_SOURCES += \
+ ephy-seed-loader.c \
+ ephy-seed-extension.c \
+ $(NULL)
+
+libephymain_la_CFLAGS += $(SEED_CFLAGS)
+libephymain_la_LIBADD += $(SEED_LIBS)
+endif # ENABLE_SEED
+
if ENABLE_PYTHON
NOINST_H_FILES += \
ephy-python.h \