aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/desktop-file/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-10-06 22:15:07 +0800
committerChristian Persch <chpe@src.gnome.org>2005-10-06 22:15:07 +0800
commit8f8805588ab31f3646fe8fb6e27191a962bc1eb8 (patch)
treef7f37db0103a242a7ccbede4cb4ddac3311f83b2 /plugins/desktop-file/Makefile.am
parent2d2e6db37dcb70a1bbded7b7abf1e5c722f61f4a (diff)
downloadgsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.gz
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.bz2
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.lz
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.xz
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.tar.zst
gsoc2013-epiphany-8f8805588ab31f3646fe8fb6e27191a962bc1eb8.zip
Add "desktop-file" plugin, adapted from the "mozilla-desktop-file-plugin"
2005-10-06 Christian Persch <chpe@cvs.gnome.org> * Makefile.am: * configure.ac: * plugins/.cvsignore: * plugins/Makefile.am: * plugins/desktop-file/.cvsignore: * plugins/desktop-file/Makefile.am: * plugins/desktop-file/plugin.cpp: * po/POTFILES.in: Add "desktop-file" plugin, adapted from the "mozilla-desktop-file-plugin" written by Jorn Baayen <jbaayen@gnome.org>. For now only handle .desktop files from file:/// URIs, for security reasons.
Diffstat (limited to 'plugins/desktop-file/Makefile.am')
-rw-r--r--plugins/desktop-file/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/desktop-file/Makefile.am b/plugins/desktop-file/Makefile.am
new file mode 100644
index 000000000..4920d9060
--- /dev/null
+++ b/plugins/desktop-file/Makefile.am
@@ -0,0 +1,20 @@
+plugindir = $(libdir)/epiphany/$(EPIPHANY_MAJOR)/plugins
+plugin_LTLIBRARIES = libdesktopfileplugin.la
+
+libdesktopfileplugin_la_SOURCES = \
+ plugin.cpp
+
+libdesktopfileplugin_la_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\"ephy-desktop-file-plugin\" \
+ -I$(top_srcdir)/lib \
+ -I$(MOZILLA_INCLUDE_ROOT) \
+ $(AM_CPPFLAGS)
+
+libdesktopfileplugin_la_CXXFLAGS = \
+ $(DESKTOP_FILE_PLUGIN_DEP_CFLAGS) \
+ $(AM_CXXFLAGS)
+
+libdesktopfileplugin_la_LIBADD = \
+ $(DESKTOP_FILE_PLUGIN_DEP_LIBS)
+
+libdesktopfileplugin_la_LDFLAGS = -module -avoid-version -R$(MOZILLA_HOME)