aboutsummaryrefslogtreecommitdiffstats
path: root/lib/widgets/Makefile.am
diff options
context:
space:
mode:
authorDiego Escalante Urrelo <descalante@igalia.com>2011-01-27 05:01:43 +0800
committerDiego Escalante Urrelo <descalante@igalia.com>2011-03-08 04:34:52 +0800
commit1463005c1bc7e30be973876db0c324021222cd8c (patch)
tree618abed7b936edae4f9c096ced4ad2e070272019 /lib/widgets/Makefile.am
parentb9f9bf1a0763492f8bf41b8856bbd1149c5871a9 (diff)
downloadgsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.tar
gsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.tar.gz
gsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.tar.bz2
gsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.tar.lz
gsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.tar.xz
gsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.tar.zst
gsoc2013-epiphany-1463005c1bc7e30be973876db0c324021222cd8c.zip
ephy-download-widget: new widget
A widget showing the progress of an EphyDownload and offering the default set of actions to take on it: Open, Browse to, Cancel. It keeps a ref to the EphyDownload its showing. Bug #618443
Diffstat (limited to 'lib/widgets/Makefile.am')
-rw-r--r--lib/widgets/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/widgets/Makefile.am b/lib/widgets/Makefile.am
index 524ecf7d0..a80cbde0f 100644
--- a/lib/widgets/Makefile.am
+++ b/lib/widgets/Makefile.am
@@ -1,6 +1,8 @@
noinst_LTLIBRARIES = libephywidgets.la
libephywidgets_la_SOURCES = \
+ ephy-download-widget.c \
+ ephy-download-widget.h \
ephy-location-entry.c \
ephy-location-entry.h \
ephy-node-view.c \
@@ -11,6 +13,8 @@ libephywidgets_la_SOURCES = \
ephy-tree-model-node.h \
ephy-tree-model-sort.c \
ephy-tree-model-sort.h \
+ totem-glow-button.c \
+ totem-glow-button.h \
ephy-zoom-action.h \
ephy-zoom-action.c \
ephy-zoom-control.c \
@@ -24,6 +28,7 @@ libephywidgets_la_CPPFLAGS = \
-I$(top_builddir)/lib \
-I$(top_builddir)/lib/widgets \
-I$(top_srcdir)/lib \
+ -I$(top_srcdir)/embed \
-I$(top_srcdir)/lib/egg \
-DSHARE_DIR=\"$(pkgdatadir)\" \
$(AM_CPPFLAGS)