aboutsummaryrefslogtreecommitdiffstats
path: root/lib/widgets/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-03-07 04:20:23 +0800
committerXan Lopez <xan@igalia.com>2012-03-07 04:49:47 +0800
commit8cc5c6df39c67e756d2cdc2aabeceb1928808187 (patch)
treed8f388f8261c6ad146246abbaf2f1c285d8e1be9 /lib/widgets/Makefile.am
parent59c3c6334c070dc7b9e34c3171dbb99374826705 (diff)
downloadgsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.tar
gsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.tar.gz
gsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.tar.bz2
gsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.tar.lz
gsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.tar.xz
gsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.tar.zst
gsoc2013-epiphany-8cc5c6df39c67e756d2cdc2aabeceb1928808187.zip
Move the host and urls views from embed to lib/widgets
Since that's their natural place. Also create a base class to hold the common code they share.
Diffstat (limited to 'lib/widgets/Makefile.am')
-rw-r--r--lib/widgets/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/widgets/Makefile.am b/lib/widgets/Makefile.am
index f581674f8..9f751e0d8 100644
--- a/lib/widgets/Makefile.am
+++ b/lib/widgets/Makefile.am
@@ -3,6 +3,12 @@ noinst_LTLIBRARIES = libephywidgets.la
libephywidgets_la_SOURCES = \
ephy-download-widget.c \
ephy-download-widget.h \
+ ephy-history-view.c \
+ ephy-history-view.h \
+ ephy-hosts-store.c \
+ ephy-hosts-store.h \
+ ephy-hosts-view.c \
+ ephy-hosts-view.h \
ephy-location-entry.c \
ephy-location-entry.h \
ephy-middle-clickable-button.c \
@@ -15,6 +21,10 @@ libephywidgets_la_SOURCES = \
ephy-tree-model-node.h \
ephy-tree-model-sort.c \
ephy-tree-model-sort.h \
+ ephy-urls-store.c \
+ ephy-urls-store.h \
+ ephy-urls-view.c \
+ ephy-urls-view.h \
ephy-zoom-action.h \
ephy-zoom-action.c \
nautilus-floating-bar.c \
@@ -28,6 +38,7 @@ libephywidgets_la_CPPFLAGS = \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/embed \
-I$(top_srcdir)/lib/egg \
+ -I$(top_srcdir)/lib/history \
-DSHARE_DIR=\"$(pkgdatadir)\" \
$(AM_CPPFLAGS)