aboutsummaryrefslogtreecommitdiffstats
path: root/lib/widgets/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2011-02-12 05:54:43 +0800
committerXan Lopez <xan@gnome.org>2011-02-12 05:54:43 +0800
commite65e2873a6d8407e9a8801e8667085ec10fa261f (patch)
tree2eb4b45b8dba349176873574678e8eca50640754 /lib/widgets/Makefile.am
parent7a6c09572386c98b7b57d5543a1e36f6642d425b (diff)
downloadgsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.tar
gsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.tar.gz
gsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.tar.bz2
gsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.tar.lz
gsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.tar.xz
gsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.tar.zst
gsoc2013-epiphany-e65e2873a6d8407e9a8801e8667085ec10fa261f.zip
Sync with upstream GeditOverlay code
Diffstat (limited to 'lib/widgets/Makefile.am')
-rw-r--r--lib/widgets/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/lib/widgets/Makefile.am b/lib/widgets/Makefile.am
index f41adac18..f1e2f0dbd 100644
--- a/lib/widgets/Makefile.am
+++ b/lib/widgets/Makefile.am
@@ -17,11 +17,13 @@ libephywidgets_la_SOURCES = \
ephy-zoom-control.h \
gedit-overlay.c \
gedit-overlay.h \
- gedit-theatrics-animated-widget.c \
- gedit-theatrics-animated-widget.h
+ gedit-overlay-child.c \
+ gedit-overlay-child.h \
+ $(BUILT_SOURCES)
libephywidgets_la_CPPFLAGS = \
-I$(top_builddir)/lib \
+ -I$(top_builddir)/lib/widgets \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/lib/egg \
-DSHARE_DIR=\"$(pkgdatadir)\" \
@@ -30,3 +32,20 @@ libephywidgets_la_CPPFLAGS = \
libephywidgets_la_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
$(AM_CFLAGS)
+
+BUILT_SOURCES = \
+ gedit-enum-types.c \
+ gedit-enum-types.h
+
+ENUM_TYPES = \
+ gedit-overlay-child.h
+
+gedit-enum-types.h: gedit-enum-types.h.template $(ENUM_TYPES) $(GLIB_MKENUMS)
+ $(AM_V_GEN)(cd $(srcdir) && $(GLIB_MKENUMS) --template gedit-enum-types.h.template $(ENUM_TYPES)) > $@
+
+gedit-enum-types.c: gedit-enum-types.c.template $(ENUM_TYPES) $(GLIB_MKENUMS)
+ $(AM_V_GEN)(cd $(srcdir) && $(GLIB_MKENUMS) --template gedit-enum-types.c.template $(ENUM_TYPES)) > $@
+
+EXTRA_DIST = \
+ gedit-enum-types.c.template \
+ gedit-enum-types.h.template