aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-01-21 02:57:20 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-01-21 02:57:20 +0800
commitc2beffd03405e6db4295afd6c2982388b808cb2e (patch)
tree819e50881626c5109ccdba5abb158585a3ca148b /lib/egg/Makefile.am
parent822ca51797e05edbe42b80f1a33a70a7327d732e (diff)
downloadgsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.tar
gsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.tar.gz
gsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.tar.bz2
gsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.tar.lz
gsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.tar.xz
gsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.tar.zst
gsoc2013-epiphany-c2beffd03405e6db4295afd6c2982388b808cb2e.zip
Merge eog-menu-api branch
2003-01-20 Marco Pesenti Gritti <marco@it.gnome.org> * Merge eog-menu-api branch
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
new file mode 100644
index 000000000..93abfd0d3
--- /dev/null
+++ b/lib/egg/Makefile.am
@@ -0,0 +1,59 @@
+INCLUDES = \
+ $(EPIPHANY_DEPENDENCY_CFLAGS) \
+ -DGTK_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DG_DISABLE_DEPRECATED
+
+noinst_LTLIBRARIES = libegg.la
+
+libegg_la_SOURCES = \
+ egg-action.c \
+ egg-action-group.c \
+ egg-toggle-action.c \
+ egg-radio-action.c \
+ egg-markup.c \
+ egg-menu-merge.c \
+ egg-accel-dialog.c \
+ eggradiotoolbutton.c \
+ eggtoggletoolbutton.c \
+ eggtoolitem.c \
+ eggseparatortoolitem.c \
+ eggtoolbar.c \
+ eggtoolbutton.c \
+ eggmarshalers.c
+
+noinst_HEADERS = \
+ egg-menu.h \
+ egg-action.h \
+ egg-action-group.h \
+ egg-toggle-action.h \
+ egg-radio-action.h \
+ egg-markup.h \
+ egg-menu-merge.h \
+ egg-accel-dialog.h \
+ eggradiotoolbutton.h \
+ eggtoggletoolbutton.h \
+ eggtoolitem.h \
+ eggseparatortoolitem.h \
+ eggtoolbar.h \
+ eggtoolbutton.h
+
+eggmarshalers.h:
+ cd $(srcdir) \
+ && $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --header > xgen-emh \
+ && cp xgen-emh eggmarshalers.h \
+ && rm -f xgen-emh xgen-emh~
+
+eggmarshalers.c:
+ cd $(srcdir) \
+ && $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --body > xgen-emc \
+ && cp xgen-emc eggmarshalers.c \
+ && rm -f xgen-emc xgen-emc~
+
+egg-marshal.c: eggmarshalers.h eggmarshalers.c
+
+noinst_HEADERS = \
+ eggmarshalers.h
+
+EXTRA_DIST= \
+ eggmarshalers.list