aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-12-01 07:35:15 +0800
committerChristian Persch <chpe@src.gnome.org>2004-12-01 07:35:15 +0800
commitcde1dbc2942cf146c01774b76ba0466e775ab761 (patch)
tree0712acb55b93089fa975528e635fc2c52d574bfe /lib/egg/Makefile.am
parent65e5b595792b3ba941db3a1f77707946fe8810ed (diff)
downloadgsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.tar
gsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.tar.gz
gsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.tar.bz2
gsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.tar.lz
gsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.tar.xz
gsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.tar.zst
gsoc2013-epiphany-cde1dbc2942cf146c01774b76ba0466e775ab761.zip
Add deprecated defines to AM_CPPFLAGS in maintainer-mode.
2004-12-01 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Add deprecated defines to AM_CPPFLAGS in maintainer-mode. * doc/reference/Makefile.am: * embed/Makefile.am: * embed/mozilla/Makefile.am: * lib/Makefile.am: * lib/egg/Makefile.am: * lib/egg/eggintl.h: * lib/widgets/Makefile.am: * src/Makefile.am: * src/bookmarks/Makefile.am: INCLUDES is deprecated, use AM_CPPFLAGS and AM_CFLAGS instead. * lib/eel-gconf-extensions.c: (eel_gconf_client_get_global): Removed usage of deprecated gconf API. * src/ephy-main.c: (main): Removed usage of deprecated glade API.
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am65
1 files changed, 34 insertions, 31 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index 4920ffbba..dc2f0c6e3 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -1,39 +1,40 @@
-INCLUDES = \
- -I$(top_builddir)/lib/egg \
- $(EPIPHANY_DEPENDENCY_CFLAGS) \
- -DCURSOR_DIR=\"$(pkgdatadir)/art\" \
- -DGTK_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DG_DISABLE_DEPRECATED
+EGGSOURCES = \
+ eggtreemultidnd.c \
+ egg-editable-toolbar.c \
+ egg-toolbars-model.c \
+ egg-toolbar-editor.c \
+ eggstatusicon.c \
+ eggtrayicon.c \
+ eggtraymanager.c
-noinst_LTLIBRARIES = libegg.la
+EGGHEADERS = \
+ eggtreemultidnd.h \
+ egg-editable-toolbar.h \
+ egg-toolbars-model.h \
+ egg-toolbar-editor.h \
+ eggstatusicon.h \
+ eggtrayicon.h \
+ eggtraymanager.h
-EGGSOURCES = \
- eggtreemultidnd.c \
- egg-editable-toolbar.c \
- egg-toolbars-model.c \
- egg-toolbar-editor.c \
- eggstatusicon.c \
- eggtrayicon.c \
- eggtraymanager.c
+noinst_HEADERS = \
+ $(EGGHEADERS) \
+ eggmarshalers.h \
+ eggintl.h
+
+noinst_LTLIBRARIES = libegg.la
libegg_la_SOURCES = \
- $(EGGSOURCES) \
- eggmarshalers.c
+ $(EGGSOURCES) \
+ eggmarshalers.c
-EGGHEADERS = \
- eggtreemultidnd.h \
- egg-editable-toolbar.h \
- egg-toolbars-model.h \
- egg-toolbar-editor.h \
- eggstatusicon.h \
- eggtrayicon.h \
- eggtraymanager.h
+libegg_la_CPPFLAGS = \
+ -I$(top_builddir)/lib/egg \
+ -DCURSOR_DIR=\"$(pkgdatadir)/art\" \
+ $(AM_CPPFLAGS)
-noinst_HEADERS = \
- $(EGGHEADERS) \
- eggmarshalers.h \
- eggintl.h
+libegg_la_CFLAGS = \
+ $(EPIPHANY_DEPENDENCY_CFLAGS) \
+ $(AM_CFLAGS)
BUILT_SOURCES = eggmarshalers.h eggmarshalers.c
@@ -41,7 +42,7 @@ eggmarshalers.h: eggmarshalers.list
$(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --header > eggmarshalers.h
eggmarshalers.c: eggmarshalers.list
- $(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --body > eggmarshalers.c
+ $(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --header --body > eggmarshalers.c
EXTRA_DIST= \
eggmarshalers.list
@@ -52,3 +53,5 @@ EGGDIR=$(srcdir)/../../../libegg/libegg
regenerate-built-sources:
EGGFILES="$(EGGFILES) eggmarshalers.list" EGGDIR="$(EGGDIR)" $(srcdir)/update-from-egg.sh
+CLEANFILES = $(BUILT_SOURCES)
+DISTCLEAN_FILES = $(BUILT_SOURCES)