aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@src.gnome.org>2003-08-30 01:17:42 +0800
committerMarco Pesenti Gritti <marco@src.gnome.org>2003-08-30 01:17:42 +0800
commit07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4 (patch)
treeffa40aa822515f159aa944d613b711bc921e6522 /lib/egg/Makefile.am
parent322e9bc21fbd27e9ee920b1908d04ba4302381df (diff)
downloadgsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.tar
gsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.tar.gz
gsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.tar.bz2
gsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.tar.lz
gsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.tar.xz
gsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.tar.zst
gsoc2013-epiphany-07f0c900d6ade15ceb7ef418aa0ea7dabd1909c4.zip
Part of gtk 2.3 port, changelog too long to paste it
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am26
1 files changed, 1 insertions, 25 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index eca7c0b14..9f55158f9 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -1,5 +1,6 @@
INCLUDES = \
$(EPIPHANY_DEPENDENCY_CFLAGS) \
+ $(WARN_CFLAGS) \
-DGTK_DISABLE_DEPRECATED \
-DGDK_DISABLE_DEPRECATED \
-DG_DISABLE_DEPRECATED
@@ -7,19 +8,7 @@ INCLUDES = \
noinst_LTLIBRARIES = libegg.la
EGGSOURCES = \
- egg-action.c \
- egg-action-group.c \
- egg-toggle-action.c \
- eggtreemodelfilter.c \
eggtreemultidnd.c \
- egg-radio-action.c \
- egg-menu-merge.c \
- eggradiotoolbutton.c \
- eggtoggletoolbutton.c \
- eggtoolitem.c \
- eggseparatortoolitem.c \
- eggtoolbar.c \
- eggtoolbutton.c \
egg-editable-toolbar.c \
egg-toolbars-model.c \
egg-toolbar-editor.c
@@ -29,20 +18,7 @@ libegg_la_SOURCES = \
eggmarshalers.c
EGGHEADERS = \
- eggtreemodelfilter.h \
eggtreemultidnd.h \
- egg-menu.h \
- egg-action.h \
- egg-action-group.h \
- egg-toggle-action.h \
- egg-radio-action.h \
- egg-menu-merge.h \
- eggradiotoolbutton.h \
- eggtoggletoolbutton.h \
- eggtoolitem.h \
- eggseparatortoolitem.h \
- eggtoolbar.h \
- eggtoolbutton.h \
egg-editable-toolbar.h \
egg-toolbars-model.h \
egg-toolbar-editor.h