aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2008-09-25 04:02:55 +0800
committerChristian Persch <chpe@src.gnome.org>2008-09-25 04:02:55 +0800
commit659169914fa8da235b35730c688a23c3caca8b3a (patch)
treeef6977c62d09ba7094c3646eb3dfd0c10b80cb62 /lib/egg/Makefile.am
parente1d7349c1c0191c371c11a9011eb288187e2cc9d (diff)
downloadgsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.tar
gsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.tar.gz
gsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.tar.bz2
gsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.tar.lz
gsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.tar.xz
gsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.tar.zst
gsoc2013-epiphany-659169914fa8da235b35730c688a23c3caca8b3a.zip
Remove libgnome and libgnomeui dependency, using EggSMClient instead of GnomeClient.
svn path=/trunk/; revision=8541
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index da1d3abe6..cc1502ad8 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -1,14 +1,24 @@
+NULL =
+
EGGSOURCES = \
eggtreemultidnd.c \
+ eggdesktopfile.c \
+ eggsmclient.c \
+ eggsmclient-xsmp.c \
egg-editable-toolbar.c \
egg-toolbars-model.c \
- egg-toolbar-editor.c
+ egg-toolbar-editor.c \
+ $(NULL)
EGGHEADERS = \
eggtreemultidnd.h \
+ eggdesktopfile.h \
+ eggsmclient.h \
+ eggsmclient-private.h \
egg-editable-toolbar.h \
egg-toolbars-model.h \
- egg-toolbar-editor.h
+ egg-toolbar-editor.h \
+ $(NULL)
noinst_HEADERS = \
$(EGGHEADERS) \
@@ -26,12 +36,16 @@ nodist_libegg_la_SOURCES = \
libegg_la_CPPFLAGS = \
-I$(top_builddir)/lib/egg \
-DCURSOR_DIR=\"$(pkgdatadir)/art\" \
+ -DG_LOG_DOMAIN=\""Egg"\" \
+ -DEGG_SM_CLIENT_BACKEND_XSMP=1 \
$(AM_CPPFLAGS)
libegg_la_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
$(AM_CFLAGS)
+libegg_la_LIBADD =
+
BUILT_SOURCES = \
eggmarshalers.c \
eggmarshalers.h \