aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@it.gnome.org>2003-04-02 02:48:50 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2003-04-02 02:48:50 +0800
commit1bf392262548cf4c6779e1bc6c550b3605aba733 (patch)
treecf7ef737a899cb44d44d4270a788b5a7ebdcc964 /lib/egg/Makefile.am
parenta040bc3b4be4f80ae661b7f2a88c78d29c480e65 (diff)
downloadgsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.tar
gsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.tar.gz
gsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.tar.bz2
gsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.tar.lz
gsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.tar.xz
gsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.tar.zst
gsoc2013-epiphany-1bf392262548cf4c6779e1bc6c550b3605aba733.zip
Use EggEditableToolbar. Update to latest versions (not EggMenuMerge, we
2003-04-01 Marco Pesenti Gritti <marco@it.gnome.org> * lib/egg/Makefile.am: * lib/egg/egg-accel-dialog.c: * lib/egg/egg-action-group.c: * lib/egg/egg-action.c: * lib/egg/egg-editable-toolbar.c: * lib/egg/egg-editable-toolbar.h: * lib/egg/egg-radio-action.c: * lib/egg/egg-toggle-action.c: * lib/egg/egg-toolbars-group.c: * lib/egg/egg-toolbars-group.h: * lib/egg/eggintl.h: * lib/egg/eggtoolbar.c: * lib/egg/eggtoolbutton.c: * lib/egg/update-from-egg.sh: Use EggEditableToolbar. Update to latest versions (not EggMenuMerge, we still need patches). WARNING: it's no more possible to drag bookmarks in the toolbar, if you depend on that feature please wait the weekend to update cvs. * lib/egg/egg-markup.c: * lib/egg/egg-markup.h: Remove, not used. * lib/widgets/Makefile.am: * lib/widgets/ephy-editable-toolbar.c: * lib/widgets/ephy-editable-toolbar.h: * lib/widgets/ephy-toolbars-group.c: * lib/widgets/ephy-toolbars-group.h: Remove. * src/prefs-dialog.c: (prefs_dialog_show_help), (prefs_dialog_response_cb): Fix a warning. * src/toolbar.c: (toolbar_get_type), (toolbar_get_action_name), (toolbar_get_action), (toolbar_class_init), (toolbar_init): * src/toolbar.h: * src/window-commands.c: (window_cmd_edit_toolbar): Update to use the egg api.
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am28
1 files changed, 22 insertions, 6 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index b903ca315..4a1448a11 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -6,12 +6,11 @@ INCLUDES = \
noinst_LTLIBRARIES = libegg.la
-libegg_la_SOURCES = \
+EGGSOURCES = \
egg-action.c \
egg-action-group.c \
egg-toggle-action.c \
egg-radio-action.c \
- egg-markup.c \
egg-menu-merge.c \
egg-accel-dialog.c \
eggradiotoolbutton.c \
@@ -20,15 +19,19 @@ libegg_la_SOURCES = \
eggseparatortoolitem.c \
eggtoolbar.c \
eggtoolbutton.c \
- eggmarshalers.c
+ eggmarshalers.c \
+ egg-editable-toolbar.c \
+ egg-toolbars-group.c
-noinst_HEADERS = \
+libegg_la_SOURCES = \
+ $(EGGSOURCES)
+
+EGGHEADERS = \
egg-menu.h \
egg-action.h \
egg-action-group.h \
egg-toggle-action.h \
egg-radio-action.h \
- egg-markup.h \
egg-menu-merge.h \
egg-accel-dialog.h \
eggradiotoolbutton.h \
@@ -37,7 +40,13 @@ noinst_HEADERS = \
eggseparatortoolitem.h \
eggtoolbar.h \
eggtoolbutton.h \
- eggmarshalers.h
+ eggmarshalers.h \
+ egg-editable-toolbar.h \
+ egg-toolbars-group.h
+
+noinst_HEADERS = \
+ $(EGGHEADERS) \
+ eggintl.h
eggmarshalers.h:
cd $(srcdir) \
@@ -55,3 +64,10 @@ egg-marshal.c: eggmarshalers.h eggmarshalers.c
EXTRA_DIST= \
eggmarshalers.list
+
+EGGFILES=$(EGGSOURCES) $(EGGHEADERS)
+EGGDIR=$(srcdir)/../../../libegg/libegg
+
+regenerate-built-sources:
+ EGGFILES="$(EGGFILES)" EGGDIR="$(EGGDIR)" $(srcdir)/update-from-egg.sh
+