aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-10 07:11:36 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-10 07:11:36 +0800
commitc841a4c82601d795e75dfec0007eb9e0e3580f53 (patch)
treec20b33ec9af8b3b05109976d0944989e73a67b7a /lib/Makefile.am
parentf7c90cf8b4189935d69b2ad6a67f3708b4afe4bd (diff)
downloadgsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.gz
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.bz2
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.lz
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.xz
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.tar.zst
gsoc2013-epiphany-c841a4c82601d795e75dfec0007eb9e0e3580f53.zip
A lib/ephy-dbus.c: A lib/ephy-dbus.h:
2005-01-10 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * lib/Makefile.am: A lib/ephy-dbus.c: A lib/ephy-dbus.h: * lib/ephy-marshal.list: * src/Makefile.am: * src/ephy-shell.c: (ephy_shell_finalize), (ephy_shell_get_dbus_service): * src/ephy-shell.h: Add experimental dbus service, disabled by default. Configure with --enable-dbus to enable.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 749c315b4..e190b9750 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -73,6 +73,23 @@ libephymisc_la_CFLAGS = \
$(EPIPHANY_DEPENDENCY_CFLAGS) \
$(AM_CFLAGS)
+libephymisc_la_LIBADD =
+
+if ENABLE_DBUS
+INST_H_FILES += \
+ ephy-dbus.h
+
+TYPES_H_FILES += \
+ ephy-dbus.h
+
+libephymisc_la_SOURCES += \
+ ephy-dbus.c
+
+libephymisc_la_CFLAGS += $(DBUS_CFLAGS)
+
+libephymisc_la_LIBADD += $(DBUS_LIBS)
+endif
+
BUILT_SOURCES = \
ephy-lib-type-builtins.c \
ephy-lib-type-builtins.h \