aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2007-03-11 21:19:16 +0800
committerChristian Persch <chpe@src.gnome.org>2007-03-11 21:19:16 +0800
commit0e02c5634ef164296f6bf451ae2b35181a787989 (patch)
tree1e9be511300d5e6cdd7926857d82a9068cadd51d /lib/Makefile.am
parentaceda79d5059f2e3368415e3e6fc02e885cc7ccf (diff)
downloadgsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.tar
gsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.tar.gz
gsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.tar.bz2
gsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.tar.lz
gsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.tar.xz
gsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.tar.zst
gsoc2013-epiphany-0e02c5634ef164296f6bf451ae2b35181a787989.zip
Regenerate the type builtins when the Makefile changes. Should fix bug
2007-03-11 Christian Persch <chpe@gnome.org> * embed/Makefile.am: * lib/Makefile.am: * lib/egg/Makefile.am: * src/Makefile.am: * src/bookmarks/Makefile.am: Regenerate the type builtins when the Makefile changes. Should fix bug #416994; no code freeze break since it's only fixing a build problem. svn path=/trunk/; revision=6948
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index dd39bd2e3..8fd4d88d3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -127,8 +127,8 @@ stamp-ephy-marshal.h: ephy-marshal.list
ephy-lib-type-builtins.c: stamp-ephy-lib-type-builtins.c Makefile
@true
-stamp-ephy-lib-type-builtins.c: $(TYPES_H_FILES)
- ( cd $(srcdir) && $(GLIB_MKENUMS) \
+stamp-ephy-lib-type-builtins.c: Makefile $(TYPES_H_FILES)
+ $(GLIB_MKENUMS) \
--fhead "#include \"ephy-lib-type-builtins.h\"\n\n" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--fprod "\n#include \"@filename@\"" \
@@ -140,15 +140,15 @@ stamp-ephy-lib-type-builtins.c: $(TYPES_H_FILES)
--vtail " { 0, NULL, NULL }\n };\n\n" \
--vtail " type = g_@type@_register_static (\"@EnumName@\", _@enum_name@_values);\n }\n\n" \
--vtail " return type;\n}\n\n" \
- $(^F) ) > xgen-$(@F) \
+ $(filter-out $<,$^) > xgen-$(@F) \
&& ( cmp -s xgen-$(@F) $(@F:stamp-%=%) || cp xgen-$(@F) $(@F:stamp-%=%) ) \
&& rm -f xgen-$(@F) \
&& echo timestamp > $(@F)
ephy-lib-type-builtins.h: stamp-ephy-lib-type-builtins.h Makefile
@true
-stamp-ephy-lib-type-builtins.h: $(TYPES_H_FILES)
- ( cd $(srcdir) && $(GLIB_MKENUMS) \
+stamp-ephy-lib-type-builtins.h: Makefile $(TYPES_H_FILES)
+ $(GLIB_MKENUMS) \
--fhead "#ifndef EPHY_LIB_TYPE_BUILTINS_H\n" \
--fhead "#define EPHY_LIB_TYPE_BUILTINS_H 1\n\n" \
--fhead "#include <glib-object.h>\n\n" \
@@ -158,7 +158,7 @@ stamp-ephy-lib-type-builtins.h: $(TYPES_H_FILES)
--fprod "\n/* --- @filename@ --- */" \
--eprod "#define EPHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
--eprod "GType @enum_name@_get_type (void);\n" \
- $(^F) ) > xgen-$(@F) \
+ $(filter-out $<,$^) > xgen-$(@F) \
&& ( cmp -s xgen-$(@F) $(@F:stamp-%=%) || cp xgen-$(@F) $(@F:stamp-%=%) ) \
&& rm -f xgen-$(@F) \
&& echo timestamp > $(@F)