aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-01-07 22:59:56 +0800
committerChristian Persch <chpe@src.gnome.org>2005-01-07 22:59:56 +0800
commit9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98 (patch)
tree98bc5c8cf2da676023ef6df17b99c11b87298de8 /lib/Makefile.am
parentc3da24579d8f707e1da5ed2a2e0040e2b724757f (diff)
downloadgsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.tar
gsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.tar.gz
gsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.tar.bz2
gsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.tar.lz
gsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.tar.xz
gsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.tar.zst
gsoc2013-epiphany-9362c2d2c2e0a386eac7a0c8f9cb683ad1e3af98.zip
Avoid unnecessary rebuilts of the generated enum .h files by using stamp
2005-01-07 Christian Persch <chpe@cvs.gnome.org> * embed/Makefile.am: * lib/Makefile.am: * lib/egg/Makefile.am: * src/Makefile.am: Avoid unnecessary rebuilts of the generated enum .h files by using stamp files.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 55312a398..6570ecf82 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -81,12 +81,20 @@ BUILT_SOURCES = \
CLEAN_FILES = $(BUILT_SOURCES)
DISTCLEAN_FILES = $(BUILT_SOURCES)
+MAINTAINERCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+
+stamp_files = \
+ stamp-ephy-lib-type-builtins.h \
+ stamp-ephy-marshal.h
ephy-marshal.c: ephy-marshal.list
$(GLIB_GENMARSHAL) --prefix=ephy_marshal $(srcdir)/ephy-marshal.list --header --body > ephy-marshal.c
-ephy-marshal.h: ephy-marshal.list
- $(GLIB_GENMARSHAL) --prefix=ephy_marshal $(srcdir)/ephy-marshal.list --header > ephy-marshal.h
+ephy-marshal.h: stamp-ephy-marshal.h
+ @true
+stamp-ephy-marshal.h: ephy-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=ephy_marshal $(srcdir)/ephy-marshal.list --header > ephy-marshal.h \
+ && echo timestamp > $(@F)
ephy-lib-type-builtins.c: $(TYPES_H_FILES)
( cd $(srcdir) && $(GLIB_MKENUMS) \
@@ -105,7 +113,9 @@ ephy-lib-type-builtins.c: $(TYPES_H_FILES)
&& ( cmp -s xgen-$(@F) $(@F) || cp xgen-$(@F) $(@F) ) \
&& rm -f xgen-$(@F)
-ephy-lib-type-builtins.h: $(TYPES_H_FILES)
+ephy-lib-type-builtins.h: stamp-ephy-lib-type-builtins.h
+ @true
+stamp-ephy-lib-type-builtins.h: $(TYPES_H_FILES)
( cd $(srcdir) && $(GLIB_MKENUMS) \
--fhead "#ifndef EPHY_LIB_TYPE_BUILTINS_H\n" \
--fhead "#define EPHY_LIB_TYPE_BUILTINS_H 1\n\n" \
@@ -117,8 +127,9 @@ ephy-lib-type-builtins.h: $(TYPES_H_FILES)
--eprod "#define EPHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
--eprod "GType @enum_name@_get_type (void);\n" \
$(^F) ) > xgen-$(@F) \
- && ( cmp -s xgen-$(@F) $(@F) || cp xgen-$(@F) $(@F) ) \
- && rm -f xgen-$(@F)
+ && ( cmp -s xgen-$(@F) $(@F:stamp-%=%) || cp xgen-$(@F) $(@F:stamp-%=%) ) \
+ && rm -f xgen-$(@F) \
+ && echo timestamp > $(@F)
EXTRA_DIST = \
ephy-marshal.list