aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2003-11-11 05:36:34 +0800
committerChristian Persch <chpe@src.gnome.org>2003-11-11 05:36:34 +0800
commit6e5d0d68dce662ca6db4a753154b010e3e82bfdc (patch)
treef58000182e2ad17e3c0dc271dd70f02cbb94927c /lib/Makefile.am
parent5dd52c6c36d647d844372b3baad27df7f014bdf6 (diff)
downloadgsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.tar
gsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.tar.gz
gsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.tar.bz2
gsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.tar.lz
gsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.tar.xz
gsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.tar.zst
gsoc2013-epiphany-6e5d0d68dce662ca6db4a753154b010e3e82bfdc.zip
New extensions API.
2003-11-10 Christian Persch <chpe@cvs.gnome.org> New extensions API. * Makefile.am: * configure.in: * lib/Makefile.am: * lib/ephy-module-loader.c: (ephy_module_loader_get_type), (ephy_module_loader_new), (ephy_module_loader_load), (ephy_module_loader_unload), (ephy_module_loader_class_init), (ephy_module_loader_init), (ephy_module_loader_finalize), (ephy_module_loader_factory): * lib/ephy-module-loader.h: * plugins/.cvsignore: * plugins/Makefile.am: * plugins/sample/.cvsignore: * plugins/sample/Makefile.am: * plugins/sample/sample.c: * src/Makefile.am: * src/bookmarks/ephy-bookmarks-editor.c: (get_target_window): * src/bookmarks/ephy-bookmarks.c: * src/ephy-automation.c: (ephy_automation_factory), (ephy_automation_factory_new), (impl_ephy_automation_loadurl), (impl_ephy_automation_load_session), (ephy_automation_class_init): * src/ephy-extension.c: (ephy_extension_get_type), (ephy_extension_attach_window), (ephy_extension_detach_window): * src/ephy-extension.h: * src/ephy-extensions-manager.c: (ephy_extensions_manager_get_type), (ephy_extensions_manager_instantiate_extension), (ephy_extensions_manager_load), (ephy_extensions_manager_load_dir), (ephy_extensions_manager_add), (ephy_extensions_manager_init), (ephy_extensions_manager_finalize), (impl_attach_window), (impl_detach_window), (ephy_extensions_manager_iface_init), (ephy_extensions_manager_class_init), (ephy_extensions_manager_new): * src/ephy-extensions-manager.h: * src/ephy-history-window.c: (get_target_window): * src/ephy-plugin.c: * src/ephy-plugin.h: * src/ephy-session.c: (ephy_session_get_type), (get_session_filename), (session_delete), (net_stop_cb), (tab_added_cb), (tab_removed_cb), (tabs_reordered_cb), (impl_attach_window), (impl_detach_window), (save_yourself_cb), (die_cb), (gnome_session_attach), (gnome_session_detach), (ensure_session_directory), (ephy_session_init), (ephy_session_dispose), (ephy_session_finalize), (ephy_session_iface_init), (ephy_session_class_init), (offer_to_resume), (ephy_session_autoresume), (ephy_session_close), (write_tab), (write_window_geometry), (write_tool_window), (write_ephy_window), (ephy_session_save), (parse_embed), (ephy_session_load), (ephy_session_get_windows), (ephy_session_add_window), (ephy_session_remove_window), (ephy_session_get_active_window): * src/ephy-session.h: * src/ephy-shell.c: (ephy_shell_init), (ephy_shell_finalize), (ephy_shell_get_session), (ephy_shell_get_extensions_manager), (toolwindow_show_cb), (toolwindow_hide_cb): * src/ephy-shell.h: * src/ephy-window.c: (ephy_window_destroy), (ephy_window_init): * src/prefs-dialog.c: (prefs_homepage_current_button_clicked_cb): * src/session.c: * src/session.h: Create a new extensions API. Make session an internal extension :) Port callers to session API changes.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am22
1 files changed, 5 insertions, 17 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index f442d34db..a899c2335 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -25,6 +25,7 @@ NOINST_H_FILES = \
ephy-gui.h \
ephy-langs.h \
ephy-marshal.h \
+ ephy-module-loader.h \
ephy-node-filter.h \
ephy-node-common.h \
ephy-prefs.h \
@@ -41,45 +42,32 @@ INST_H_FILES = \
libephy_la_SOURCES = \
eel-gconf-extensions.c \
- eel-gconf-extensions.h \
- ephy-bonobo-extensions.h \
ephy-bonobo-extensions.c \
ephy-debug.c \
- ephy-debug.h \
ephy-dialog.c \
- ephy-dialog.h \
ephy-dnd.c \
- ephy-dnd.h \
ephy-file-chooser.c \
ephy-file-helpers.c \
- ephy-file-helpers.h \
ephy-glade.c \
- ephy-glade.h \
ephy-gui.c \
ephy-gui.h \
- ephy-langs.h \
ephy-langs.c \
+ ephy-module-loader.c \
ephy-marshal.c \
- ephy-marshal.h \
ephy-node.c \
ephy-node.h \
ephy-node-filter.c \
- ephy-node-filter.h \
ephy-node-common.h \
ephy-node-db.c \
- ephy-node-db.h \
ephy-prefs.h \
ephy-state.c \
- ephy-state.h \
ephy-string.c \
- ephy-string.h \
ephy-stock-icons.c \
- ephy-stock-icons.h \
ephy-thread-helpers.c \
- ephy-thread-helpers.h \
ephy-types.h \
- ephy-zoom.h \
- ephy-zoom.c
+ ephy-zoom.c \
+ $(INST_H_FILES) \
+ $(NOINST_H_FILES)
libephy_la_LIBADD = \
$(top_builddir)/lib/widgets/libephywidgets.la \