aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpeseng@src.gnome.org>2002-12-31 03:29:24 +0800
committerMarco Pesenti Gritti <mpeseng@src.gnome.org>2002-12-31 03:29:24 +0800
commit6876ede98282c7db318089bfefb292aa59e55d48 (patch)
tree76b23252d04da232d0ebf22e53bfe3e022686af9 /lib/Makefile.am
downloadgsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.tar
gsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.tar.gz
gsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.tar.bz2
gsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.tar.lz
gsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.tar.xz
gsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.tar.zst
gsoc2013-epiphany-6876ede98282c7db318089bfefb292aa59e55d48.zip
Initial revision
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 000000000..60092472f
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,73 @@
+SUBDIRS = widgets toolbar
+
+INCLUDES = \
+ $(WARN_CFLAGS) \
+ $(EPIPHANY_DEPENDENCY_CFLAGS) \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DG_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGNOME_DISABLE_DEPRECATED
+
+noinst_LTLIBRARIES = libephy.la
+
+libephy_la_SOURCES = \
+ ephy-types.h \
+ ephy-prefs.h \
+ ephy-gobject-misc.h \
+ eel-gconf-extensions.c \
+ eel-gconf-extensions.h \
+ ephy-dialog.c \
+ ephy-dialog.h \
+ ephy-dnd.c \
+ ephy-dnd.h \
+ ephy-marshal.c \
+ ephy-marshal.h \
+ ephy-types.h \
+ ephy-bonobo-extensions.h \
+ ephy-bonobo-extensions.c \
+ ephy-file-helpers.c \
+ ephy-file-helpers.h \
+ ephy-glade.c \
+ ephy-glade.h \
+ ephy-gui.c \
+ ephy-gui.h \
+ ephy-prefs-utils.c \
+ ephy-prefs-utils.h \
+ ephy-state.c \
+ ephy-state.h \
+ ephy-string.c \
+ ephy-string.h \
+ ephy-autocompletion.c \
+ ephy-autocompletion.h \
+ ephy-autocompletion-source.c \
+ ephy-autocompletion-source.h \
+ ephy-stock-icons.c \
+ ephy-stock-icons.h \
+ ephy-filesystem-autocompletion.c \
+ ephy-filesystem-autocompletion.h \
+ ephy-thread-helpers.c \
+ ephy-thread-helpers.h \
+ ephy-node.c \
+ ephy-node.h \
+ ephy-node-filter.c \
+ ephy-node-filter.h
+
+libephy_la_LIBADD = \
+ $(top_builddir)/lib/widgets/libephywidgets.la \
+ $(top_builddir)/lib/toolbar/libephytoolbar.la
+
+BUILT_SOURCES=ephy-marshal.c ephy-marshal.h
+
+CLEAN_FILES = $(BUILT_SOURCES)
+
+ephy-marshal.c: ephy-marshal.list
+ @GLIB_GENMARSHAL@ --prefix=ephy_marshal $(srcdir)/ephy-marshal.list --header --body > ephy-marshal.c
+
+ephy-marshal.h: ephy-marshal.list
+ @GLIB_GENMARSHAL@ --prefix=ephy_marshal $(srcdir)/ephy-marshal.list --header > ephy-marshal.h
+
+EXTRA_DIST = \
+ ephy-marshal.list
+