aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-06-09 06:48:29 +0800
committerChristian Persch <chpe@src.gnome.org>2006-06-09 06:48:29 +0800
commit6d84e196d76acdcc56908bc8ec1484f8e3d614b6 (patch)
tree9c5cc5a936b08273d9bda4d97c616cc2b91362d6 /lib/Makefile.am
parent5d74d2227e45c916bbe44289684737a49b2e3c77 (diff)
downloadgsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.tar
gsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.tar.gz
gsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.tar.bz2
gsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.tar.lz
gsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.tar.xz
gsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.tar.zst
gsoc2013-epiphany-6d84e196d76acdcc56908bc8ec1484f8e3d614b6.zip
Check for enchant, and output an overview of the configured options on
2006-06-09 Christian Persch <chpe@cvs.gnome.org> * configure.ac: Check for enchant, and output an overview of the configured options on successful configure. * data/default-prefs-common.js: * embed/mozilla/GeckoSpellCheckEngine.cpp: * embed/mozilla/GeckoSpellCheckEngine.h: * embed/mozilla/Makefile.am: * embed/mozilla/MozRegisterComponents.cpp: * lib/Makefile.am: * lib/ephy-spell-check.c: * lib/ephy-spell-check.h: Spell check support using the gecko 'spellchecker' extension. No corrections context menu or language switching yet.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 697213940..439c356bb 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -82,6 +82,18 @@ libephymisc_la_CFLAGS = \
libephymisc_la_LIBADD =
+if ENABLE_SPELLCHECKER
+libephymisc_la_SOURCES += \
+ ephy-spell-check.c \
+ ephy-spell-check.h
+
+libephymisc_la_CFLAGS += \
+ $(SPELLCHECKER_CFLAGS)
+
+libephymisc_la_LIBADD += \
+ $(SPELLCHECKER_LIBS)
+endif
+
BUILT_SOURCES = \
ephy-lib-type-builtins.c \
ephy-lib-type-builtins.h \