aboutsummaryrefslogtreecommitdiffstats
path: root/embed/mozilla/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2004-11-20 04:13:44 +0800
committerChristian Persch <chpe@src.gnome.org>2004-11-20 04:13:44 +0800
commitb0e668237680c11a5e3189d367ea1dbc7544d130 (patch)
treee1414d4016b9712fa5c5415ffc3b8b2404fc5c45 /embed/mozilla/Makefile.am
parentc98367a38ddb3af23365caa49a0684e7ba7750ef (diff)
downloadgsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.gz
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.bz2
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.lz
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.xz
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.tar.zst
gsoc2013-epiphany-b0e668237680c11a5e3189d367ea1dbc7544d130.zip
Add --disable-filepicker to use when the mozilla build itself has native
2004-11-19 Christian Persch <chpe@cvs.gnome.org> * configure.ac: * embed/mozilla/Makefile.am: * embed/mozilla/MozRegisterComponents.cpp: Add --disable-filepicker to use when the mozilla build itself has native gtk+ filepicker.
Diffstat (limited to 'embed/mozilla/Makefile.am')
-rw-r--r--embed/mozilla/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/embed/mozilla/Makefile.am b/embed/mozilla/Makefile.am
index 747be8078..029956db0 100644
--- a/embed/mozilla/Makefile.am
+++ b/embed/mozilla/Makefile.am
@@ -64,8 +64,6 @@ libephymozillaembed_la_SOURCES = \
EphyUtils.h \
EventContext.cpp \
EventContext.h \
- FilePicker.cpp \
- FilePicker.h \
GlobalHistory.cpp \
GlobalHistory.h \
GtkNSSClientAuthDialogs.cpp \
@@ -94,3 +92,9 @@ libephymozillaembed_la_SOURCES = \
mozilla-embed-single.h \
mozilla-notifiers.cpp \
mozilla-notifiers.h
+
+if ENABLE_FILEPICKER
+libephymozillaembed_la_SOURCES += \
+ FilePicker.cpp \
+ FilePicker.h
+endif