aboutsummaryrefslogtreecommitdiffstats
path: root/embed/mozilla/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2005-10-13 03:33:48 +0800
committerChristian Persch <chpe@src.gnome.org>2005-10-13 03:33:48 +0800
commit5f02d1125ef8c08ebd3d145565b6f054084f2658 (patch)
treecefc5495f05835cb37a983cebc715769e4c86158 /embed/mozilla/Makefile.am
parentfefc4bfb69cb7a69c87328c132ed8f38142b6a74 (diff)
downloadgsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.tar
gsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.tar.gz
gsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.tar.bz2
gsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.tar.lz
gsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.tar.xz
gsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.tar.zst
gsoc2013-epiphany-5f02d1125ef8c08ebd3d145565b6f054084f2658.zip
A embed/mozilla/EphyRedirectChannel.cpp: A
2005-10-12 Christian Persch <chpe@cvs.gnome.org> * embed/mozilla/EphyAboutModule.cpp: * embed/mozilla/EphyAboutModule.h: A embed/mozilla/EphyRedirectChannel.cpp: A embed/mozilla/EphyRedirectChannel.h: * embed/mozilla/Makefile.am: Implement about:recover. Build the about module on all geckos, and only #ifdef the about:neterror implementation for gecko 1.8. * src/ephy-session.c: (tab_added_cb), (impl_attach_window), (ephy_session_autoresume), (write_tab), (ephy_session_save), (parse_embed), (ephy_session_load): Record the page load status and page title in the session file, and use about:recover when the page was still loading when the browser crashed. 2005-10-10 Christian Persch <chpe@cvs.gnome.org>
Diffstat (limited to 'embed/mozilla/Makefile.am')
-rw-r--r--embed/mozilla/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/embed/mozilla/Makefile.am b/embed/mozilla/Makefile.am
index fd10910fe..86ee39abd 100644
--- a/embed/mozilla/Makefile.am
+++ b/embed/mozilla/Makefile.am
@@ -3,6 +3,8 @@ noinst_LTLIBRARIES = libephymozillaembed.la
libephymozillaembed_la_SOURCES = \
ContentHandler.cpp \
ContentHandler.h \
+ EphyAboutModule.cpp \
+ EphyAboutModule.h \
EphyContentPolicy.cpp \
EphyContentPolicy.h \
EphyHeaderSniffer.cpp \
@@ -13,6 +15,8 @@ libephymozillaembed_la_SOURCES = \
EphyFind.h \
EphyHistoryListener.cpp \
EphyHistoryListener.h \
+ EphyRedirectChannel.cpp \
+ EphyRedirectChannel.h \
EphySidebar.cpp \
EphySidebar.h \
EphySingle.cpp \
@@ -64,12 +68,6 @@ libephymozillaembed_la_SOURCES += \
GtkNSSSecurityWarningDialogs.h
endif
-if HAVE_GECKO_1_8
-libephymozillaembed_la_SOURCES += \
- EphyAboutModule.cpp \
- EphyAboutModule.h
-endif
-
mozilla_include_subdirs = \
caps \
chardet \