aboutsummaryrefslogtreecommitdiffstats
path: root/embed/mozilla/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2008-04-04 05:09:48 +0800
committerChristian Persch <chpe@src.gnome.org>2008-04-04 05:09:48 +0800
commit39e984581c9ff4531e527456facf30f74574a64f (patch)
tree230720b87280b53b96058205a39f9d12b448e408 /embed/mozilla/Makefile.am
parent18325ac0850ff053477580b448fc6d1b7f21afa8 (diff)
downloadgsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.tar
gsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.tar.gz
gsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.tar.bz2
gsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.tar.lz
gsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.tar.xz
gsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.tar.zst
gsoc2013-epiphany-39e984581c9ff4531e527456facf30f74574a64f.zip
Remove this too
svn path=/trunk/; revision=8184
Diffstat (limited to 'embed/mozilla/Makefile.am')
-rw-r--r--embed/mozilla/Makefile.am176
1 files changed, 0 insertions, 176 deletions
diff --git a/embed/mozilla/Makefile.am b/embed/mozilla/Makefile.am
deleted file mode 100644
index c669d399a..000000000
--- a/embed/mozilla/Makefile.am
+++ /dev/null
@@ -1,176 +0,0 @@
-noinst_LTLIBRARIES = libephymozillaembed.la
-
-libephymozillaembed_la_SOURCES = \
- AutoJSContextStack.cpp \
- AutoJSContextStack.h \
- AutoModalDialog.cpp \
- AutoModalDialog.h \
- AutoWindowModalState.cpp \
- AutoWindowModalState.h \
- ContentHandler.cpp \
- ContentHandler.h \
- EphyAboutModule.cpp \
- EphyAboutModule.h \
- EphyContentPolicy.cpp \
- EphyContentPolicy.h \
- EphyHeaderSniffer.cpp \
- EphyHeaderSniffer.h \
- EphyBrowser.cpp \
- EphyBrowser.h \
- EphyFind.cpp \
- EphyFind.h \
- EphyHistoryListener.cpp \
- EphyHistoryListener.h \
- EphyPromptService.cpp \
- EphyPromptService.h \
- EphyRedirectChannel.cpp \
- EphyRedirectChannel.h \
- EphySidebar.cpp \
- EphySidebar.h \
- EphySingle.cpp \
- EphySingle.h \
- EphyUtils.cpp \
- EphyUtils.h \
- EventContext.cpp \
- EventContext.h \
- GeckoCookiePromptService.cpp \
- GeckoCookiePromptService.h \
- GeckoFormSigningDialog.cpp \
- GeckoFormSigningDialog.h \
- GeckoPrintService.cpp \
- GeckoPrintService.h \
- GeckoPrintSession.cpp \
- GeckoPrintSession.h \
- GlobalHistory.cpp \
- GlobalHistory.h \
- MozDownload.cpp \
- MozDownload.h \
- MozRegisterComponents.cpp \
- MozRegisterComponents.h \
- mozilla-download.cpp \
- mozilla-download.h \
- mozilla-embed.cpp \
- mozilla-embed.h \
- mozilla-embed-event.cpp \
- mozilla-embed-event.h \
- mozilla-embed-find.cpp \
- mozilla-embed-find.h \
- mozilla-embed-persist.cpp \
- mozilla-embed-persist.h \
- mozilla-embed-single.cpp \
- mozilla-embed-single.h \
- mozilla-history-item.cpp \
- mozilla-history-item.h \
- mozilla-notifiers.cpp \
- mozilla-notifiers.h
-
-if !HAVE_GECKO_1_9
-libephymozillaembed_la_SOURCES += \
- EphyBadCertRejector.cpp \
- EphyBadCertRejector.h \
- EphyDirectoryProvider.cpp \
- EphyDirectoryProvider.h \
- $(NULL)
-endif
-
-if ENABLE_FILEPICKER
-libephymozillaembed_la_SOURCES += \
- FilePicker.cpp \
- FilePicker.h
-endif
-
-if HAVE_MOZILLA_PSM
-libephymozillaembed_la_SOURCES += \
- GtkNSSClientAuthDialogs.cpp \
- GtkNSSClientAuthDialogs.h \
- GtkNSSDialogs.cpp \
- GtkNSSDialogs.h \
- GtkNSSKeyPairDialogs.cpp \
- GtkNSSKeyPairDialogs.h \
- GtkNSSSecurityWarningDialogs.cpp\
- GtkNSSSecurityWarningDialogs.h
-endif
-
-
-if ENABLE_SPELLCHECKER
-libephymozillaembed_la_SOURCES += \
- GeckoSpellCheckEngine.cpp \
- GeckoSpellCheckEngine.h
-endif
-
-mozilla_include_subdirs = \
- . \
- caps \
- chardet \
- chrome \
- commandhandler \
- content \
- cookie \
- docshell \
- dom \
- exthandler \
- fastfind \
- helperAppDlg \
- find \
- gfx \
- gtkembedmoz \
- history \
- js \
- layout \
- locale \
- mimetype \
- necko \
- nkcache \
- passwordmgr \
- pipboot \
- pipnss \
- pref \
- shistory \
- string \
- sidebar \
- spellchecker \
- uriloader \
- uconv \
- wallet \
- webbrowserpersist \
- webbrwsr \
- widget \
- windowwatcher \
- xmlextras \
- xpcom \
- xpconnect
-
-libephymozillaembed_la_CPPFLAGS = \
- -I$(top_srcdir)/lib \
- -I$(top_srcdir)/embed \
- -I$(top_srcdir) \
- $(addprefix -I$(GECKO_INCLUDE_ROOT)/,$(mozilla_include_subdirs)) \
- -DSHARE_DIR=\"$(pkgdatadir)\" \
- -DPLUGINDIR=\"$(libdir)/epiphany/$(EPIPHANY_MAJOR)/plugins\" \
- -DMOZILLA_HOME=\"$(GECKO_HOME)\" \
- -DMOZILLA_PREFIX=\"$(GECKO_PREFIX)\" \
- -DMOZILLA_NATIVE_PLUGINSDIR=\"$(libdir)/mozilla/plugins\" \
- -DUA_VERSION=\"$(EPIPHANY_UA_VERSION)\" \
- -DALLOW_PRIVATE_API \
- $(AM_CPPFLAGS)
-
-if HAVE_GECKO_1_9
-if HAVE_GECKO_XPCOM_GLUE
-libephymozillaembed_la_CPPFLAGS += \
- -DXPCOM_GLUE_USE_NSPR
-endif
-endif
-
-libephymozillaembed_la_CXXFLAGS = \
- $(GECKO_CFLAGS) \
- $(DEPENDENCIES_CFLAGS) \
- $(AM_CXXFLAGS)
-
-if HAVE_GECKO_1_9
-xptdir = $(pkgdatadir)/components
-xpt_DATA = epiphany.xpt
-
-noinst_DATA = \
- ephyIAddCertExceptionParams.idl \
- ephyIAddCertExceptionParams.h
-endif