aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2013-03-07 00:57:17 +0800
committerCarlos Garcia Campos <carlosgc@gnome.org>2013-03-07 03:16:54 +0800
commite4884cdab61ed2ddc0c69b51175d41f11cc1ded6 (patch)
tree023ec87c4860a3988b75602fad70d507d90f901e /embed/Makefile.am
parent80ea62552d2e08dc2e990c5820678a06157ae416 (diff)
downloadgsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.tar
gsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.tar.gz
gsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.tar.bz2
gsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.tar.lz
gsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.tar.xz
gsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.tar.zst
gsoc2013-epiphany-e4884cdab61ed2ddc0c69b51175d41f11cc1ded6.zip
Do not build adblock files in libephyembed for WebKit2
The required files will be built in the web extension.
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index 467cc5453..c85988864 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -13,12 +13,9 @@ NOINST_H_FILES = \
ephy-encoding.h \
ephy-encodings.h \
ephy-file-monitor.h \
- ephy-request-about.h \
- uri-tester.h
+ ephy-request-about.h
INST_H_FILES = \
- ephy-adblock.h \
- ephy-adblock-manager.h \
ephy-download.h \
ephy-embed.h \
ephy-embed-container.h \
@@ -37,8 +34,6 @@ BUILT_SOURCES = \
libephyembed_la_SOURCES = \
ephy-about-handler.c \
- ephy-adblock.c \
- ephy-adblock-manager.c \
ephy-download.c \
ephy-embed.c \
ephy-embed-container.c \
@@ -54,10 +49,19 @@ libephyembed_la_SOURCES = \
ephy-request-about.c \
ephy-embed-prefs.c \
ephy-web-view.c \
- uri-tester.c \
$(INST_H_FILES) \
$(NOINST_H_FILES)
+if !WITH_WEBKIT2
+libephyembed_la_SOURCES += \
+ ephy-adblock.c \
+ ephy-adblock.h \
+ ephy-adblock-manager.c \
+ ephy-adblock-manager.h \
+ uri-tester.c \
+ uri-tester.h
+endif
+
nodist_libephyembed_la_SOURCES = \
$(BUILT_SOURCES)