aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@gnome.org>2003-11-22 19:32:34 +0800
committerMarco Pesenti Gritti <marco@src.gnome.org>2003-11-22 19:32:34 +0800
commita0e702ef16f5e52c9c366713934c07aa3dc2ce7a (patch)
treee9f71380e21af46897b068308cb1983d942f920e /embed/Makefile.am
parentd961598c3761da5a673acef2d2f7abd33586f1c1 (diff)
downloadgsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.tar
gsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.tar.gz
gsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.tar.bz2
gsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.tar.lz
gsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.tar.xz
gsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.tar.zst
gsoc2013-epiphany-a0e702ef16f5e52c9c366713934c07aa3dc2ce7a.zip
Add a factory to create embed objects and use it. Deal with dependency of
2003-11-22 Marco Pesenti Gritti <marco@gnome.org> * doc/reference/Makefile.am: * embed/Makefile.am: * embed/ephy-embed-persist.c: (ephy_embed_persist_save): * embed/ephy-embed-persist.h: * embed/ephy-embed-popup-control.c: (save_url), (embed_popup_set_image_as_background_cmd): * embed/ephy-embed-shell.c: (ephy_embed_shell_get_embed_single): * embed/ephy-embed.c: * embed/ephy-embed.h: * embed/ephy-favicon-cache.c: (ephy_favicon_cache_download): * embed/mozilla/mozilla-embed-persist.cpp: * embed/mozilla/mozilla-embed-single.cpp: * embed/mozilla/mozilla-embed-single.h: * embed/mozilla/mozilla-embed.cpp: * src/Makefile.am: * src/ephy-nautilus-view.c: (ephy_nautilus_view_instance_init): * src/ephy-tab.c: (ephy_tab_init): * src/popup-commands.c: (save_property_url), (popup_cmd_set_image_as_background): * src/window-commands.c: (window_cmd_file_save_as), (save_temp_source): Add a factory to create embed objects and use it. Deal with dependency of mozilla-embed and mozilla-embed-persist on mozilla-embed-single internally.
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index 511050639..e082e2c91 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -13,7 +13,7 @@ INCLUDES += -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
-DGNOME_DISABLE_DEPRECATED -DBONOBO_DISABLE_DEPRECATED $(WARN_CFLAGS)
endif
-noinst_LTLIBRARIES = libephyembed.la
+noinst_LTLIBRARIES = libephyembed.la libephyembedfactory.la
headerdir = $(prefix)/include/epiphany-@EPIPHANY_MAJOR@/epiphany
header_DATA = $(INST_H_FILES)
@@ -63,4 +63,6 @@ libephyembed_la_SOURCES = \
$(INST_H_FILES) \
$(NOINST_H_FILES)
-libephyembed_la_LIBADD = $(top_builddir)/embed/mozilla/libephymozillaembed.la
+libephyembedfactory_la_SOURCES = \
+ ephy-embed-factory.c \
+ ephy-embed-factory.h