aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@cvs.gnome.org>2006-01-03 22:42:10 +0800
committerChristian Persch <chpe@src.gnome.org>2006-01-03 22:42:10 +0800
commit23858a10ce281167073b9e0b82375fc53256310a (patch)
tree6d59df47d5370d7384520ed6fcd1fe0e262235b6 /embed/Makefile.am
parent440c60d5ce97f899426a8a12700277f8c06d11db (diff)
downloadgsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.gz
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.bz2
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.lz
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.xz
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.tar.zst
gsoc2013-epiphany-23858a10ce281167073b9e0b82375fc53256310a.zip
Don't include generated files in the tarball. Bug #319440.
2006-01-03 Christian Persch <chpe@cvs.gnome.org> * embed/Makefile.am: * embed/mozilla/Makefile.am: * lib/Makefile.am: * lib/egg/Makefile.am: * src/Makefile.am: * src/bookmarks/Makefile.am: Don't include generated files in the tarball. Bug #319440. R help/C/Makefile.am: R help/es/Makefile.am: R help/eu/Makefile.am: R help/fi/Makefile.am: R help/ja/Makefile.am: R help/uk/Makefile.am: Remove obsolete files.
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index b97b81d54..3be8a73b2 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -31,6 +31,10 @@ INST_H_FILES = \
ephy-password-manager.h \
ephy-permission-manager.h
+BUILT_SOURCES = \
+ ephy-embed-type-builtins.c \
+ ephy-embed-type-builtins.h
+
libephyembed_la_SOURCES = \
ephy-adblock-manager.c \
downloader-view.c \
@@ -51,8 +55,7 @@ libephyembed_la_SOURCES = \
ephy-permission-manager.c \
print-dialog.c \
$(INST_H_FILES) \
- $(NOINST_H_FILES) \
- $(BUILT_SOURCES)
+ $(NOINST_H_FILES)
if ENABLE_CERTIFICATE_MANAGER
INST_H_FILES += \
@@ -64,6 +67,9 @@ libephyembed_la_SOURCES += \
ephy-x509-cert.c
endif
+nodist_libephyembed_la_SOURCES = \
+ $(BUILT_SOURCES)
+
libephyembed_la_CPPFLAGS = \
-I$(top_builddir)/lib \
-I$(top_srcdir)/embed/mozilla \
@@ -91,10 +97,6 @@ libephyembedfactory_la_CFLAGS = \
$(DEPENDENCIES_CFLAGS) \
$(AM_CFLAGS)
-BUILT_SOURCES = \
- ephy-embed-type-builtins.c \
- ephy-embed-type-builtins.h
-
CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
MAINTAINERCLEANFILES = $(stamp_files) $(BUILT_SOURCES)