aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2007-09-10 05:11:39 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-10 05:11:39 +0800
commitb3a75061677399de19355802c54c4d355653f284 (patch)
tree689385d476a8034eb7d5fd1d7939b7b01b6468eb /embed/Makefile.am
parent0e3d0325dab1bfa25b1af72cc8b1f8dcddfa9dc7 (diff)
downloadgsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.gz
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.bz2
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.lz
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.xz
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.tar.zst
gsoc2013-epiphany-b3a75061677399de19355802c54c4d355653f284.zip
A m4/libxul.m4: Integrate the "xulrunner" backend with configure. Not
2007-09-09 Christian Persch <chpe@gnome.org> * configure.ac: * embed/Makefile.am: * embed/ephy-embed-factory.c: (ephy_embed_factory_new_object): * m4/gecko.m4: A m4/libxul.m4: * src/Makefile.am: Integrate the "xulrunner" backend with configure. Not building yet. svn path=/trunk/; revision=7359
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index e073b5d57..f6b432aab 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -1,9 +1,12 @@
SUBDIRS = $(with_engine)
-DIST_SUBDIRS = mozilla webkit
+
+DIST_SUBDIRS = xulrunner mozilla webkit
+
+NULL =
noinst_LTLIBRARIES = libephyembed.la libephyembedfactory.la
-headerdir = $(prefix)/include/epiphany/@EPIPHANY_MAJOR@/epiphany
+headerdir = $(prefix)/include/epiphany/$(EPIPHANY_MAJOR)/epiphany
header_DATA = \
ephy-embed-type-builtins.h \
$(INST_H_FILES)
@@ -91,6 +94,13 @@ libephyembedfactory_la_CPPFLAGS = \
-I$(top_srcdir)/embed/$(with_engine) \
$(AM_CPPFLAGS)
+if WITH_XULRUNNER_ENGINE
+libephyembedfactory_la_CPPFLAGS += \
+ -I$(srcdir)xulrunner/embed \
+ $(LIBXUL_INCLUDES) \
+ $(NULL)
+endif
+
if WITH_GECKO_ENGINE
libephyembedfactory_la_CPPFLAGS += -I$(GECKO_INCLUDE_ROOT)/gtkembedmoz
endif